Mailinglist Archive: opensuse-factory (381 mails)

< Previous Next >
[opensuse-factory] Fwd: Bug? Re: problem with static linking. of util-linux utils meant to be statically linkable...


So I should file this as a bug against factory or tumbleweed? There
was some disagreement about whether or not they should be treated
the same?

Because these utils 'should' be statically linkable and *are* on
redhat (which I thought opensuse was based on). So how
did static linking get broken for us but still work for redhat?



-------- Original Message --------
Subject: problem with static linking. of util-linux utils meant to be
statically linkable...
Date: Sat, 06 Oct 2018 12:30:59 -0700
From: L A Walsh <suse@xxxxxxxxx>
To: SuSE Linux <opensuse@xxxxxxxxxxxx>

Was trying the rc1 version of util-linux 2.33, and it has an option
to link several of its utils statically.

It works for the maintainer on redhat, and I was wondering why
I'm having problems on opensuse...

$ ./configure --enable-static-programs=mount,umount
$ make mount.static umount.static
.....

so I see... Except I got:

CC sys-utils/mount_static-mount.o
CCLD mount.static
libtool: warning: complete static linking is impossible in this configuration
/usr/bin/ld: total time in link: 0.038189
CC sys-utils/umount_static-umount.o
CCLD umount.static
libtool: warning: complete static linking is impossible in this configuration
/usr/bin/ld: total time in link: 0.039017

with ldd:
Ishtar:tools/util-linux/util-linux-2.33-rc1> ldd mount.static
linux-vdso.so.1 (0x00007ffc38d78000)
librt.so.1 => /lib64/librt.so.1 (0x0000003001c00000)
libc.so.6 => /lib64/libc.so.6 (0x0000003000800000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003000c00000)
/lib64/ld-linux-x86-64.so.2 (0x00007f81b9262000)


So why would it work on redhat but not opensuse? Any ideas?






--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >