Mailinglist Archive: opensuse-factory (226 mails)

< Previous Next >
Re: [opensuse-factory] Since 20180827 akondi / Google issue
  • From: Wolfgang Bauer <wbauer@xxxxxx>
  • Date: Mon, 17 Sep 2018 21:31:36 +0200
  • Message-id: <1562454.25UICfoh5M@amiga>
Am Mittwoch, 29. August 2018, 18:23:25 schrieb Knurpht-openSUSE:
Op woensdag 29 augustus 2018 18:01:31 CEST schreef Michal Hlavac:
Can't add gmail account with imap.gmail.com server after this release.

Akonadi says:

KGAPI2::ContactsGroupFetchJob(0x55819e871090) "Invalid authentication."
org.kde.pim.kimap: sasl_client_start failed with: -4 "SASL(-4): no
mechanism available: No worthy mechs found"
I ran into that just half an hour ago. I bypassed the auto configuration,
which selected Gmail as an auth, where it should be PLAIN. Most likely
Google changed the API again.

Actually, as it turned out we have a packaging error/regression in our 18.08
packages. (the SASL plugin for Google authorization was moved from kdepim-
runtime to libkgapi upstream which required packaging changes)

See https://bugzilla.opensuse.org/show_bug.cgi?id=1108577 and
https://bugs.kde.org/show_bug.cgi?id=375410 .

A fix is on the way...

As a workaround for now, you can install libkgapi-devel (which contains the
"missing" libkdexoauth2.so), or create the symlink (in /usr/lib64/sasl2/)
manually.
Then "GMail" authorization should work again like before.

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages