Mailinglist Archive: opensuse-factory (383 mails)

< Previous Next >
Re: [opensuse-factory] RMT dependencies


On 29/08/2018 17:04, simonizor wrote:
On Wednesday, August 29, 2018 2:12:36 AM CDT, Simon Lees wrote:

On 29/08/2018 07:41, hellcp@xxxxxxxxxxxx wrote:
Hi,
With schily being modified in Factory it appears that it collides with
star-rmt,
tar-rmt and cpio-mt showing this message:

Problem: schily-mt-2018.05.25-4.1.x86_64 conflicts with cpio-mt
provided ...
A quick search of the patterns indicates we are not installing those
packages from there so I guess the question then becomes what packages
are pulling those in as dependencies, or it could just be that your
machine was setup before we made major changes to the patterns and
something else used to pull them in.

I tried uninstalling cpio-mt after I saw that message, and then I ran a
second dup.  schily-mt was pulled in anyways.  I have no pattern
packages installed, and I have recommended packages turned off globally.
I've had this install since November of last year; I'll check my laptop
later to see if it has cpio-mt also.

It looks like update-alternatives should be setup to swap between all
the *-rmt packages so i'm not quite sure why the conflicts line also
exists, seems like a bug in the package.

--

Simon Lees (Simotek) http://simotek.net

Emergency Update Team keybase.io/simotek
SUSE Linux Adelaide Australia, UTC+10:30
GPG Fingerprint: 5B87 DB9D 88DC F606 E489 CEC5 0922 C246 02F0 014B

< Previous Next >
Follow Ups