Mailinglist Archive: opensuse-factory (244 mails)

< Previous Next >
Re: [opensuse-factory] Vagrant and Ruby 2.5 in openSUSE
On Monday, 23 July 2018 09:37:46 CEST Gerben Venekamp wrote:
On Tuesday, 17 July 2018 15:32:09 CEST Robert Munteanu wrote:
Hi Gerben,

On Sat, Jul 14, 2018 at 8:10 AM, Gerben Venekamp

<gm.venekamp@xxxxxxxxxxx> wrote:
I am unable to install some plugins for vagrant, e.g. vagrant-virtlib
and
vagrant-kvm. Vagrant will try to compile these plugin first and install
the
result as a Ruby gem. An number of devel packages are required for a
successful compilation. One of those is ruby-devel.

The reason for failing to compile, I think, is because Vagrant is
shipped
with an embedded Ruby. This embedded version is 2.4 and openSUSE ships
Ruby 2.5 and hence no proper devel package for Ruby 2.4 is installed. I
have tried to manually install Ruby 2.4 using rvm. Although I could tell
I had Ruby 2.4 running by looking at the output of 'ruby --version', not
all necessary Ruby files had been installed it seemed as the gem
generation was still failing with the same error.

My question is how do I resolve the above issue of having an embedded
Ruby
2.4 within vagrant and not having the devel packages for that embedded
version?

It sounds like you are using the RPM provided by upstream. Is that
correct?

That is both a yes and a no. I have tried both. My guess would be that
vagrant is not produced with Ruby 2.5 on TW, but rather the binary file
from vagrant is taken. However, I do not know how to test this hypothesis.

I updated to TW20180720 yesterday and this morning things seem to be working
again.

vagrant plugin install vagrant-libvirt
==> vagrant: A new version of Vagrant is available: 2.1.2!
==> vagrant: To upgrade visit: https://www.vagrantup.com/downloads.html

Installing the 'vagrant-libvirt' plugin. This can take a few minutes...
Fetching: excon-0.62.0.gem (100%)
Fetching: formatador-0.2.5.gem (100%)
Fetching: fog-core-1.43.0.gem (100%)
Fetching: fog-json-1.2.0.gem (100%)
Fetching: fog-xml-0.1.3.gem (100%)
Fetching: fog-libvirt-0.5.0.gem (100%)
Fetching: vagrant-libvirt-0.0.43.gem (100%)
Installed the plugin 'vagrant-libvirt (0.0.43)'!

Cheers,
Gerben


Cheers,
Gerben

I would recommend that you use the RPM provided by openSUSE,
although when I last tried plugin installation still did not work.

Robert




--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups