Mailinglist Archive: opensuse-factory (138 mails)

< Previous Next >
Re: [opensuse-factory] TW 20180627: Many games stoped working
  • From: Peter Suetterlin <pit@xxxxxxxxxxx>
  • Date: Mon, 2 Jul 2018 09:34:32 +0100
  • Message-id: <20180702083432.3inspp4s6aetfedn@woodstock.pitnet>
Knurpht@openSUSE wrote:
Op zondag 1 juli 2018 23:16:20 CEST schreef Peter Suetterlin:
Hi list,

Since the update to mentioned TW version 20180627 several games stopped
working for me. Common seems to be the message(s)

X Error of failed request: BadValue (integer parameter out of range for
operation) Major opcode of failed request: 152 (XFree86-VidModeExtension)
Minor opcode of failed request: 10 (XF86VidModeSwitchToMode)
Value in failed request: 0x193
Serial number of failed request: 46
Current serial number in output stream: 50

I'm not really sure what to make of this message - anyone with more insight?
I must have to do with fullscreen modes. E.g., atari800 runs windowed, but
when I switch to fullscreen I only get a black screen + cursor and have to
switch to a VT to kill the process. Same symptoms with some other games
that directly want to start fullscreen.

Anyone seen similar problems?

And the games involved?

Given the symptoms it's less an issue of the games, but of some other system
component that has changed. FWIW, except for the already mentioned atari800
it's quake (darkplaces engine), einstein, Jaspers Journey. Likely more,
didn't have time to test all hundreds of games :o

The DE used?

KDE. Will have to check if I have some other WM installed for a test.
But you should probably rather have asked for the GPU (which is an Intel
HD530), at least googling for this error messages always points to X or the
GPU driver.

Did the '28 upgrade fix it?

Not yet tested, I first wanted to look at older snapshots, and an update is
likely to nuke some of those.
At least that revealed that already 20180625 (which is the oldest I have) has
the problem.

But it clearly seems connected to the change of resolution. If I start the
atari800 emulator specifying FS resolution,
'atari800 -fullscreen -fs-width 2560 -fs-height 1440' it does not have to
switch resolution, and then it runs.

Doesn't help for other games that don't offer a similar command line option...
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups