Mailinglist Archive: opensuse-factory (536 mails)

< Previous Next >
[opensuse-factory] NVIDIA/Leap 15.0: Console (VT) not working with external display
25.05.2018 11:30, Till Dörges пишет:
Hello all,


I have a laptop with openSUSE Leap 15.0 and an external monitor running
nicely - if I
use X.

But I cannot use the virtual terminals on the external display.


If I switch to a virtual terminal/console (e.g. by pressing STRG-ALT-F1), my
monitor
displays nothing and goes into powersave.

On the laptop display I get a virtual terminal (crappy resolution, but that's
not
really an issue).


For VGA based console (including vesafb) output is determined by default
adapter settings, probably controlled by BIOS.

KMS framebuffer drivers should actually output to all connected monitors
by default. I briefly tested on my notebook; initial BIOS and bootloader
output goes to internal display; as soon as inteldrmfb is loaded output
is duplicated to TV connected by HDMI. All in text mode.

Since I couldn't get the external display working with the default nouveau, I
tried

Not sure what you mean here. It does not work in X11/Wayland or it does
not work in text console?

the proprietary drivers. I'm now running these RPMs:

user@box:~> rpm -qa nvidia-*
nvidia-computeG04-390.59-lp150.8.1.x86_64
nvidia-gfxG04-kmp-default-390.59_k4.12.14_lp150.11-lp150.8.1.x86_64
nvidia-glG04-390.59-lp150.8.1.x86_64

My Graphics adapter is an "nVidia GM107GLM [Quadro M1200 Mobile]".


Well, to my best knowledge nVidia does not offer DRM framebuffer driver
at all, so you get just single display. You may be able to configure
which one in BIOS setup or card properties using nVidia utilities.
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References