Mailinglist Archive: opensuse-factory (536 mails)

< Previous Next >
[opensuse-factory] Re: Please fix this before the release...
  • From: Andreas Schwab <schwab@xxxxxxx>
  • Date: Tue, 22 May 2018 10:05:43 +0200
  • Message-id: <mvm4lj0t8rs.fsf@suse.de>
On Mai 18 2018, Jimmy Berry <jberry@xxxxxxxx> wrote:

- Packman

<repository name="openSUSE_Leap_42.3">
<path project="openSUSE.org:openSUSE:Leap:42.3:Update"
repository="standard"/>
<path project="openSUSE.org:openSUSE:Leap:42.3:Update" repository="ports"/

<repository name="openSUSE_Leap_15.0">
<path project="openSUSE.org:openSUSE:Leap:15.0:Update"
repository="standard"/>
<path project="openSUSE.org:openSUSE:Leap:15.0:Update" repository="ports"/


Summary, Packman has the same config for 15.0 as 42.3. Leap has a different
ports config for 15.0 and should be changed to match. Presumably others on
OBS
will have a similar problem when building against ports on OBS.

A workaround is to use separate repositories for standard and ports
architectures.

I don't understand why OBS does not find the x86_64 binaries needed since a
path element explicitly includes the standard repo. The ports repository does
not have x86_64 available so how it is seemingly "overriding" is bizarre.

Only the last path element is recursively expanded, and
openSUSE:Leap:15.0:Update/ports has no connection to
openSUSE:Leap:15.0/standard.

Andreas.

--
Andreas Schwab, SUSE Labs, schwab@xxxxxxx
GPG Key fingerprint = 0196 BAD8 1CE9 1970 F4BE 1748 E4D4 88E3 0EEA B9D7
"And now for something completely different."
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups