Mailinglist Archive: opensuse-factory (536 mails)

< Previous Next >
Re: [opensuse-factory] Leap 15 enters RC phase, package freeze ahead
  • From: Stefan Brüns <stefan.bruens@xxxxxxxxxxxxxx>
  • Date: Sun, 6 May 2018 18:28:24 +0200
  • Message-id: <4619797.aChGdvFKB1@pebbles>
On Montag, 23. April 2018 17:27:14 CEST Ludwig Nussel wrote:
Kaigue7 wrote:
KiCad 5 has just begun with its RC phase.
Will there be any chance that this can be installed in Leap 15? v4.0.7
is already quite outdated.

It's the most current stable release advertised by the upstream web
site so it can hardly be outdated.

It makes sense to work with upstream on the next version though to
make sure it doesn't use libraries we can't upgrade on 15, in case
the new upstream release is meant to be shipped with 15.1.

The typical problem of fast progressing projects with long release cycles -
the very moment a new release appears, every second user has switched to an
unstable snapshots already.

So feature wise, 4.0.7 *is* outdated. 5.0 is around the corner, but how long
it takes until the release is done is hard to say - maybe 1 month, maybe 3
months ...

"I think we are ready to tag rc2. I'm giving everyone another day or two to
make any commits that contain UI string changes before I tag rc2. Once rc2 is
tagged, no UI string changes will be allowed except for spelling errors.
Hopefully there are no more critical bugs and we can begin the countdown the
stable 5 release. Thank you everyone for your support in making this happen."

- https://lists.launchpad.net/kicad-developers/msg35537.html

Although the message is 2 weeks old, RC2 has not yet been tagged, go figure.


That said, I am currently in the process to clean up the Kicad packages to
have it ready when the upstream release happens.

The only missing dependency in Leap 15.0 is libngspice, which is not part of
Factory either (just created a SR, https://build.opensuse.org/request/show/
604632). As it is a new package with not other dependees, it should be
possible to include it in 15.1.

For Leap 15.0, you will have to use the obs://science/ for Kicad 5.0.

Kind regards,

Stefan

--
Stefan Brüns / Bergstraße 21 / 52062 Aachen
home: +49 241 53809034 mobile: +49 151 50412019
< Previous Next >
This Thread
  • No further messages