Mailinglist Archive: opensuse-factory (745 mails)

< Previous Next >
Re: [opensuse-factory] Re: Leap 15.0 Build 109.3 released!
On 01/27/2018 04:50 PM, Verwijs wrote:
Leap 15 beta, having trouble with writing MBR, new installation does not
boot...

No problems with that here.

Check for a BIOS setting that protects the MBR.

Also check whether your disk uses GPT partitioning. You might not be
able to boot from the MBR with GPT, unless you have created a BIOS BOOT
partition.

And a general note: I've been testing Leap 15.0 with EUFI and with
legacy booting.

Today I tried a clean install in a freshly created VM (under KVM). The
partitioner wanted to use GPT partitioning. When it did that, it also
setup a BIOS BOOT partition, and installing to boot from MBR was fine.

I tried a second time. This time, I used CTRL-ALT-F2 to get a command
prompt, while the license screen was still showing. I ran "fdisk" an
the virtual disk. That show DOS partitioning (legacy partitioning). So
I used "w" within "fdisk" to save the result, without actually creating
any partitions. Then, when I got to the partitioning section of the
installer, it continued with DOS partitioning. So that seems to be the
way to force DOS partitioning if you need to do that. Installing
booting in the MBR was fine.

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References