Mailinglist Archive: opensuse-factory (745 mails)

< Previous Next >
[opensuse-factory] TW: Sound issues (or rather plasma panel?)


Just noticed (for the second time) that my plasma panel showed the volume muted,
looking at the config it claimed 'no devices available'

Which is strange, as Audacious has been playing music all the time, and changing
volume from audacious did nicely work.

The system log showed consecutive entries

Jan 28 17:17:52 lux rtkit-daemon[3305]: Successfully made thread 7348 of
process 7348 (/usr/bin/pulseaudio) owned by 'pit' high priority at nice level
Jan 28 17:17:52 lux rtkit-daemon[3305]: Supervising 4 threads of 2 processes of
1 users.
Jan 28 17:17:55 lux pulseaudio[7348]: [pulseaudio] socket-server.c: bind():
Address already in use
Jan 28 17:17:55 lux pulseaudio[7348]: [pulseaudio] module.c: Failed to load
module "module-esound-protocol-unix" (argument: ""): initialization failed.
Jan 28 17:17:55 lux pulseaudio[7348]: [pulseaudio] main.c: Module load failed.
Jan 28 17:17:55 lux pulseaudio[7348]: [pulseaudio] main.c: Failed to initialize
Jan 28 17:17:55 lux pulseaudio[7345]: [pulseaudio] main.c: Daemon startup

This shows up every 15 minutes, with changing PIDs for pulsaudio.
All the time PA had been running with another PID, from initial login.

I tried restarting pulseaudio (systemctl --user restart pulseaudio), which
worked, but still no connection to the panel volume control.

For crosscheck I installed pavucontrol, and when I started it suddenly also
plasma saw the device again.

All fine I thought, started playing music in audacious again - but now the Tray
icon of audacious doesn't work. It pops up in the tray, when I start the
program, but I cannot use it to control audacious, and when I start playing a
song from the application, the tray icon still says 'no media playing'.

So something's broken - but what? Is it the panel, pulseaudio, rtkit, the
communication bus?

(This is latest TW, i.e., 20180126)
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >