Mailinglist Archive: opensuse-factory (745 mails)

< Previous Next >
[opensuse-factory] Re: new requirement bundle-lang-common-ar, re: New Tumbleweed snapshot 20180117 released!
  • From: Andreas Schwab <schwab@xxxxxxx>
  • Date: Mon, 22 Jan 2018 12:07:08 +0100
  • Message-id: <mvm7esam9sz.fsf@suse.de>
On Jan 20 2018, Andrei Borzenkov <arvidjaar@xxxxxxxxx> wrote:

20.01.2018 11:47, Thorsten Kukuk пишет:
On Sat, Jan 20, Andrei Borzenkov wrote:

But anyway, this sounds wrong. Requires does not offer any means to
select the right package so the whole still relies on the correct
package being selected by Supplements; but then what is the print of
using Requires in the first place?

Where is a Requires for bundle-lang-*?

I can only find Supplements, Recommends and Conflicts.

Thorsten


libstorage-ng1 Requires libstorage-ng-lang
Each bundle-lang-common-XX Priovides libstorage-ng-lang

I think the issue can happen if there is an inconsistency between what
the *-lang package provides and what the bundle-lang-* packages
provide. The NVR they provide should always match.

Andreas.

--
Andreas Schwab, SUSE Labs, schwab@xxxxxxx
GPG Key fingerprint = 0196 BAD8 1CE9 1970 F4BE 1748 E4D4 88E3 0EEA B9D7
"And now for something completely different."
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >