Mailinglist Archive: opensuse-factory (745 mails)

< Previous Next >
Re: [opensuse-factory] new requirement bundle-lang-common-ar, re: New Tumbleweed snapshot 20180117 released!
20.01.2018 01:11, Patrick Shanahan пишет:
* Dominique Leuenberger <dimstar@xxxxxxx> [01-19-18 15:00]:

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180117

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:

why is bundle-lang-common-ar now required for packages (on my system):

GimpResourcesThumbnailer 2.1.2-1.346
amarok 2.8.0-97.2
autoyast2 4.0.22-1.1
autoyast2-installation 4.0.22-1.1
baloo_kcm 0.1+20141112-2.46
bluedevil 2.1.1-27.45
breeze4-style 5.11.5-1.1
bundle-lang-common-ar 13.2-65.1
kate4-parts 4.14.3-17.15
kde4-kgreeter-plugins 4.11.22-14.1
kdebase4-runtime 17.08.3-4.18
kdebase4-workspace-addons 4.11.22-14.1
kdebase4-workspace-liboxygenstyle 4.11.22-14.1
kdebase4-workspace-libs 4.11.22-14.1
kdelibs4 4.14.38-59.17
kdelibs4-branding-openSUSE 13.2-9.11
kdelibs4-core 4.14.38-59.17
kdepimlibs4 4.14.10-27.3
kdm 4.11.22-14.1
kio_mtp 0.75-6.8
knutclient 1.0.5-6.14
knutclient-doc 1.0.5-6.14
konsole4-part 4.14.3-22.17
kopete 17.08.3-1.3
krandr 4.11.22-14.1
krename 4.0.9-20.27
kscd 17.08.3-60.3
kvkbd 0.7.2-30.45
kwalletmanager 15.04.3-2.53
kwin 4.11.22-14.1
libakonadi4 4.14.10-27.3
libkatepartinterfaces4 4.14.3-17.15
libkcddb4 16.08.3-1.26
libkcompactdisc4 16.08.3-1.28
libkde4 4.14.38-59.17
libkdegames6 14.12.3-10.10
libkdepimlibs4 4.14.10-27.3
libkmahjongglib4 14.12.3-9.13
libkscreen 1.0.5-2.11
libksuseinstall1 4.14.38-59.17
libstorage-ng-ruby 3.3.112-1.1
libstorage-ng1 3.3.112-1.1
plasmoid-cwp 1.12.0-16.63
yast2-add-on 4.0.5-1.1
yast2-bootloader 4.0.13-1.1
yast2-country 4.0.16-1.1
yast2-inetd 4.0.0-1.1
yast2-inetd-doc 4.0.0-1.1
yast2-installation 4.0.22-1.1
yast2-iscsi-client 3.1.30-1.2
yast2-ldap 3.1.14-1.3
yast2-mail 4.0.0-1.1
yast2-metapackage-handler 3.1.4-2.5
yast2-network 4.0.13-1.1
yast2-nis-client 4.0.0-1.2
yast2-ntp-client 4.0.6-1.1
yast2-online-update 3.1.11-1.5
yast2-online-update-frontend 3.1.11-1.5
yast2-packager 4.0.29-1.1
yast2-samba-server 3.2.2-1.1
yast2-storage-ng 4.0.69-1.1
yast2-sudo 3.1.2-1.4
yast2-tune 4.0.0-1.1
yast2-update 4.0.8-1.1
yast2-users 4.0.1-1.2
yast2-vm 3.2.4-1.2


rpm -e bundle-lang-common-ar
error: Failed dependencies:
libstorage-ng-lang is needed by (installed)
libstorage-ng1-3.3.112-1.1.x86_64



If you look at "zypper info --provides bundle-lang-common-XX" you will
see that *every* bundle-lang-common provides the same language components:

or@10:~> zypper info --provides bundle-lang-common-ar
Loading repository data...
Reading installed packages...


Information for package bundle-lang-common-ar:
----------------------------------------------
Repository : openSUSE-20170729-0
Name : bundle-lang-common-ar
Version : 13.2-65.1
Arch : noarch
Vendor : openSUSE
Installed Size : 689.2 KiB
Installed : No
Status : not installed
Source package : bundle-lang-common-13.2-65.1.src
Summary : Translations for a Group of Programs
Description :
This package groups translations for a dozen of programs which are both
on the GNOME and KDE CD into languages, not split out into extra
packages.
Provides : [115]
...
libsoup-lang = 2.60.2
libstorage-ng-lang = 3.3.112
parted-lang = 3.2
psmisc-lang = 23.0
...
bor@10:~> zypper info --provides bundle-lang-common-ca
Loading repository data...
Reading installed packages...


Information for package bundle-lang-common-ca:
----------------------------------------------
Repository : openSUSE-20170729-0
Name : bundle-lang-common-ca
Version : 13.2-65.1
Arch : noarch
Vendor : openSUSE
Installed Size : 2.0 MiB
Installed : No
Status : not installed
Source package : bundle-lang-common-13.2-65.1.src
Summary : Translations for a Group of Programs
Description :
This package groups translations for a dozen of programs which are both
on the GNOME and KDE CD into languages, not split out into extra
packages.
Provides : [115]
...
libsoup-lang = 2.60.2
libstorage-ng-lang = 3.3.112
parted-lang = 3.2
psmisc-lang = 23.0
...

bor@10:~> zypper se --requires libstorage-ng-lang
Loading repository data...
Reading installed packages...

S | Name | Summary | Type
--+----------------+--------------------------------+--------
| libstorage-ng1 | Library for storage management | package
bor@10:~>


So zypper picks /some/ package providing libstorage-ng-lang which
happened to be bundle-common-lang-ar.

You can workaround it by pre-installing the "correct"
bundle-common-lang-XX (probably XX == en). But this also means there is
no indication what language user prefers. Do we have any place where
locales user wants to have on the system are recorded?
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups