Mailinglist Archive: opensuse-factory (536 mails)

< Previous Next >
Re: [opensuse-factory] latest evolution 3.26.3-1.1 is NOT compatible with latest libwebkit2gtk-4_0-37 2.18.4-1.1
Am Montag, den 08.01.2018, 15:21 +0100 schrieb Dominique Leuenberger / DimStar:
On Mon, 2018-01-08 at 14:13 +0000, Rainer Klier wrote:
ok, this means, in the future, whenever i try to update a single package,
and it again fails, then i have to disable
all
the other repos, so that only the tumbleweed repos are valid any more, and
then do a "zypper dup" to resolve the
"unknown" issue.
this will, of course, downgrade ALL the packages from other repos, where
packages from tumblewwed repos are older,
and
these have to be upgraded then again afterwards....

What other repos do you have enabled? Are you missing packages in TW or

some google repos (chrome, earth, musicmanager)
some microsoft repos (dotnet, powershell)
gcc
c_c++
python
svn
devel tools
filesystems
games tools
games
gnome apps
graphics
KDE applications
KDE distro factory
KDE extra
KDE frameworks5
KDE Qt5
kernel standard
libreoffice factory
mono factory
mozilla factory
multimedia apps, libs and photo
samba
network
printing
shells
virtualization
remotedesktop
x11 utilities
xorg factory
vlc
packman
skype
and some home: repos for some exotic packages

yes, i know, this is quite much.
yes, i know, i would/could also live with only the standard tumbleweed repos.
yes, i know, updating becomes more complex with that many repos enabled.

but normally it works perfectly, and i have latest versions of everything i
need.

before using tumbleweed i used 13.2.
and my first idea about tumbleweed was, that i have latest version of opensuse,
and latest packages available.
but not, that i always have to update the WHOLE system......

do you track devel projects to be 'even faster with updates'?

i have only some repos where i want latest version of the packages they contain.

If you miss packages, best to work with the current package maintainers
to get things into TW proper; if you have devel prjs added because you

i think most of the packages of the repos mentioned above will sooner or later
appear in new version also in TW repos.
but i want them, as soon as they are built and available, and don't want to
wait for them to appear in TW repo.....
and my opinion was, that this is exactly what TW is all about....
i thought that this is the idea behind TW.

In essence: try to keep your repo list for TW as short as possible: not

yes, understood.

but it simply should not happen that when i cherry-pick in yast some package
from TW repo to be updated, that it
updates, does NOT show/warn me about a conflict/dependency and then the
application crashes.

in a package-manager-world this is the worst thing to happen.
this is the reason for using a package-manager, so that such situation can't
happen.....
--












Best Regards | Freundliche Grüße | Cordialement | Cordiali Saluti |
Atenciosamente | Saludos Cordiales


DI Rainer Klier


Research & Development, DevOps




_________________________________________________________





Namirial GmbH






< Previous Next >