Mailinglist Archive: opensuse-factory (447 mails)

< Previous Next >
Re: [opensuse-factory] latest evolution 3.26.3-1.1 is NOT compatible with latest libwebkit2gtk-4_0-37 2.18.4-1.1
  • From: Brüns, Stefan <Stefan.Bruens@xxxxxxxxxxxxxx>
  • Date: Mon, 8 Jan 2018 13:55:57 +0000
  • Message-id: <7742315.IDlmlYJF1k@sbruens-linux>
On Montag, 8. Januar 2018 14:44:19 CET Rainer Klier wrote:
Am Montag, den 08.01.2018, 12:08 +0100 schrieb Knurpht - Gertjan Lettink:

Op maandag 8 januari 2018 11:34:53 CET schreef Rainer Klier:

Am Montag, den 08.01.2018, 11:16 +0100 schrieb Dominique Leuenberger /
DimStar:


How? Using zypper dup?



no.

i opened yast and selected both (evolution and libwebkit2gtk) for
update.
both were updated from the same tumbleweed repo.
evolution to version 3.26.3-1.1, and libwebkit2gtk-4_0-37 to version
2.18.4-1.1





no conflict or dependency error was shown.
everything was "green" and ok, even after check in yast for any
problems.
so i continued to install the updates.




and that's wrong. TW should *only* be updated through 'zypper dup'.
Nothing
else.



but why?
tumbleweed repos are like every other repos.

Format wise yes, content wise no. The TW repo from today may contain
completely different packages than the one from yesterday. The packages from
todays repo are built using the other packages from todays repo.

As long as not all upstreams provide correctly versioned libraries, zypper dup
is required before installing any new software.

Regards,

Stefan--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups