Mailinglist Archive: opensuse-factory (454 mails)

< Previous Next >
Re: [opensuse-factory] fcitx to write in CJK in calibre
  • From: Chan Ju Ping <email@xxxxxxxxx>
  • Date: Wed, 27 Dec 2017 11:29:07 +0800
  • Message-id: <5123610.PxZgWSmctB@inari>
On Tuesday, 26 December 2017 21:15:57 +08 John Paul Adrian Glaubitz wrote:
Hi Chan!

On 12/26/2017 03:02 AM, Chan Ju Ping wrote:
I was wondering whether there is a recommended method for writing in CJK
within calibre. I am currently searching by pasting the CJK text from Kate
into the search bar in calibre.

Honestly, I would just remove fcitx and reinstall ibus. At least that's
what I did to be able to use Japanese input again.

I don't know why some upstream projects decided to prefer fcitx over
ibus but for me fcitx is a huge step backwards compared to ibus.

When I started using CJK input on Linux, I first used SCIM back in the
days and getting it to work properly was quite painful. I was so happy
when ibus became mainstream because CJK input just worked once it was
set up once. Then someone decided that fcitx is the new cool thing and
all of a sudden, CJK input completely stopped working for me.

I first tried setting up fcitx, but the whole user interface was so
confusing that I did not manage to get Japanese input working. At some
point, I just removed fcitx and set a lock on the package so it wouldn't
get reinstalled automatically to break CJK input again.


I have fcitx set up just right though after several confusing configurations
including writing in Traditional Chinese rather than Simplified Chinese. Too
invested at this point!
< Previous Next >