Mailinglist Archive: opensuse-factory (454 mails)

< Previous Next >
[opensuse-factory] Re: openssl dependency problems with snapshot 20171129
On Mon, 2017-12-11 at 11:46 +0100, Andreas Schwab wrote:
On Dez 02 2017, Dominique Leuenberger / DimStar <dimstar@xxxxxxxxxxxx
wrote:

Qt4 apps can still be used and can still be built for Tumbleweed.

Not in general.

In general yes

<buildinfo project="openSUSE:Factory" repository="standard"
package="kmymoney"
downloadurl="http://download.opensuse.org/repositories";>;
<arch>x86_64</arch>
<error>unresolvable: libopenssl-1_0_0-devel conflicts with
libopenssl-devel</error>
<srcmd5>2d37f0343beac7cd16c7dbc36b6c24cb</srcmd5>
<verifymd5>2d37f0343beac7cd16c7dbc36b6c24cb</verifymd5>
<rev>54</rev>
<specfile>kmymoney.spec</specfile>
<file>kmymoney.spec</file>
<versrel>4.8.0-8</versrel>
<bcnt>3</bcnt>
<release>8.3</release>
<debuginfo>1</debuginfo>
<subpack>kmymoney</subpack>
<subpack>kmymoney-debuginfo</subpack>
<subpack>kmymoney-debugsource</subpack>
<subpack>kmymoney-devel</subpack>
<subpack>kmymoney-doc</subpack>
<subpack>kmymoney-lang</subpack>
</buildinfo>

One app does not nullify 'in general'; For this specific app you need
to find out what pulls in libopenssl-devel and what pulls in openssl-
1_0_0-devel; it might well be possible to simply put a Buildignore:
openssl-devel in place and be done with it.

Cheers
Dominique
< Previous Next >
Follow Ups