Mailinglist Archive: opensuse-factory (454 mails)

< Previous Next >
Re: [opensuse-factory] Can't provide file '' from repository = 20171129
  • From: Knurpht - Gertjan Lettink <knurpht@xxxxxxxxxxxx>
  • Date: Sat, 02 Dec 2017 12:26:24 +0100
  • Message-id: <5061107.QBYHuYuNmr@knurpht-hp>
Op zaterdag 2 december 2017 11:00:06 CET schreef C. Brouerius van Nidek:
On Saturday, December 2, 2017 2:44:42 PM WIB Felix Miata wrote:
C. Brouerius van Nidek composed on 2017-12-02 17:29 (UTC+0700):
Felix Miata wrote:
C. Brouerius van Nidek composed on 2017-12-02 13:59 (UTC+0700):
My update of snapshot 20171129 stops with following remark. The remark
follows the retrieval of 37 of a total of 447 files.
Retry give the same info at once and ignore is of no help either.
It looks like zypper has some problems with a hardlink.
No idea how to repair such a problem.

--------------------------------
[download.opensuse.org-oss|http://download.opensuse.org/tumbleweed/rep
o/
os
s/] Can't provide file '' from repository 'download.opensuse.org-oss'
History:
- Can't hardlink/copy /var/adm/mount/AP_0x97QIwY to
/var/cache/zypp/packages/ download.opensuse.org-oss
- Can't provide

Abort, retry, ignore? [a/r/i] (a):
The first of those two files looks like a temp file of some kind. It
never

happened to me. I have no idea why it would happen, unless /var/cache/
and

/var/adm/ are on separate filesystems. I would try:
zypper clean; zypper ref

to see if it clears up.

tried it out but after a fresh zypper dup I get the same result.
Did not do the trick.
Other ideas? ;)

What are the file attributes of the file and the permissions of the

directory?

What are the filesystem type(s) of that file and directory?

Maybe try forcing a / filesystem check on reboot:
# touch /forcefsck

Thanks for the ideas but I have first updated my system with Yast which does
not seem to have any trouble.

That's wrong. The only way to properly update TW is through zypper dup.

After the reboot after the update I just wanted to see if my zypper is
working now but loh and behold, the same error after starting the download
three really simple files. again the same error information.

So now it is time to make bug report but against what? Zypper or ???


--
Gertjan Lettink, a.k.a. Knurpht

openSUSE Board Member
openSUSE Forums Team
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >