Mailinglist Archive: opensuse-factory (454 mails)

< Previous Next >
Re: [opensuse-factory] openssl dependency problems with snapshot 20171129
On Fri, 2017-12-01 at 13:47 +0100, Roger Oberholtzer wrote:
On Fri, Dec 1, 2017 at 12:14 PM, Stratos Zolotas <strzol@xxxxxxxxx>
wrote:

*now* zypper dup makes me confident again

The following 5 packages are going to be REMOVED:
libgps22 libopenssl-1_0_0-devel libSPIRV-Tools-suse3 openssl-
1_0_0
pam-modules-32bit

gpsd.spec in OBS has this:

BuildRequires: pkgconfig(QtCore) >= 4.5.3
BuildRequires: pkgconfig(QtNetwork) >= 4.5.3

The OBS build used QT4 and not QT5. I suspect that is generally the
case in OBS?

The sumbols are Qt4 symbols.. the Qt5 ones are called Qt5Core and
Qt5Network.

So there is no way OBS could potentially chose Qt5 with those deps
specified - this is a packagers choice.

cheers
Dominique
< Previous Next >
Follow Ups