Mailinglist Archive: opensuse-factory (454 mails)

< Previous Next >
Re: [opensuse-factory] openssl dependency problems with snapshot 20171129
On Fri, 01 Dec 2017 10:43:11 +0100, Dominique Leuenberger / DimStar
<dimstar@xxxxxxxxxxxx> wrote:

On Fri, 2017-12-01 at 10:32 +0100, H.Merijn Brand wrote:
I didn't want to remove it at all. I just used it to demonstrate the
feedback. removing libopenssl-1_0_0-devel suggests to uninstall even
more

# rpm -qa | grep openssl | sort
libopenssl1_0_0-1.0.2m-1.1.x86_64
libopenssl1_0_0-32bit-1.0.2m-1.1.x86_64
libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64
libopenssl1_0_0-steam-32bit-1.0.2m-1.1.x86_64
libopenssl1_1_0-1.1.0g-2.1.x86_64
libopenssl1_1_0-32bit-1.1.0g-2.1.x86_64
libopenssl-devel-1.0.2m-1.1.noarch
openssl-1_0_0-1.0.2m-1.1.x86_64
openssl-1.0.2m-1.1.noarch
php7-openssl-7.1.11-2.2.x86_64

call zypper dup - and at the question on how to handle openssl upgrade,
pick the option to uninstall libopenssl-1_0_0-devel

Oh, I did, and I chose Cancel :)

# zypper dup
Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you continue.
See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
2 Problems:
Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 conflicts with
libopenssl-devel > 1.0.2m provided by libopenssl-devel-1.1.0g-1.1.noarch
Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 requires openssl-1_0_0 =
1.0.2m, but this requirement cannot be provided

Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 conflicts with
libopenssl-devel > 1.0.2m provided by libopenssl-devel-1.1.0g-1.1.noarch
Solution 1: deinstallation of libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64
Solution 2: deinstallation of libopenssl-devel-1.0.2m-1.1.noarch
Solution 3: keep obsolete libopenssl-devel-1.0.2m-1.1.noarch

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c]
(c): 1

Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 requires openssl-1_0_0 =
1.0.2m, but this requirement cannot be provided
Solution 1: Following actions will be done:
deinstallation of openssl-1.0.2m-1.1.noarch
deinstallation of sendmail-starttls-8.15.2-10.2.noarch
deinstallation of ca-certificates-2+git20170807.10b2785-1.2.noarch
deinstallation of kernel-syms-4.14.2-1.6.x86_64
deinstallation of kernel-syms-4.14.1-1.4.x86_64
deinstallation of ca-certificates-mozilla-2.11-2.1.noarch
deinstallation of python2-certifi-2017.11.5-1.1.noarch
deinstallation of python2-httplib2-0.10.3-1.1.noarch
deinstallation of python2-requests-2.18.4-1.1.noarch
deinstallation of python3-certifi-2017.11.5-1.1.noarch
deinstallation of python3-pip-9.0.1-3.1.noarch
deinstallation of python3-requests-2.18.4-1.1.noarch
deinstallation of python3-Sphinx-1.6.5-1.2.noarch
deinstallation of dbus-sharp-0.7.0-17.7.noarch
deinstallation of dbus-sharp-glib-0.5.0-14.5.noarch
deinstallation of dbus-sharp-glib2-0.6.0-1.5.noarch
deinstallation of dbus-sharp2-0.8.1-2.3.noarch
deinstallation of log4net-1.2.10-75.8.noarch
deinstallation of mono-addins-1.3-2.3.noarch
deinstallation of mono-basic-4.6-1.2.noarch
deinstallation of xsp-3.0.11-9.1.noarch
deinstallation of taglib-sharp-2.1.0.0-7.12.noarch
deinstallation of nunit-2.6.4-2.3.noarch
deinstallation of ndesk-dbus-glib-0.4.1-59.5.noarch
deinstallation of ndesk-dbus-0.6.0-85.8.noarch
deinstallation of libpurple-branding-openSUSE-42.2-1.4.noarch
deinstallation of zypper-migration-plugin-0.10.1488806253.1c712c3-1.2.noarch
deinstallation of rollback-helper-0.1-2.1.noarch
deinstallation of tomboy-lang-1.15.9-1.2.noarch
deinstallation of system-config-printer-applet-1.5.7-12.1.noarch
deinstallation of python3-Sphinx-doc-man-1.6.5-1.2.noarch
deinstallation of python3-docrepr-0.1.0-1.2.noarch
Solution 2: deinstallation of libqt4-devel-4.8.7-9.1.x86_64
Solution 3: keep obsolete openssl-1.0.2m-1.1.noarch
Solution 4: break libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 by ignoring some of
its dependencies

Choose from above solutions by number or skip, retry or cancel
[1/2/3/4/s/r/c] (c):

e.g. I check if packages are removed. For most, (often) a zupper dup
will show the removal of packages where a newer version is installed,
but e.g. kernel-syms removes all with no newer available. Why?

Why are ca-certificates removed instead of upgraded/updated?

There is no reason trying to do the whole migration manually. Let
computers do what they can best: find solutions to tricky problems.

I agree, but I like to keep my stuff working till I am confident.

My "normal" procedure

1. save the list of currently installed packages
# rpm -qa --queryformat='%{NAME}\n' | sort -u > TW-`date '+%Y%m%d'`.lst

2. Refresh repos
# zypper ref

3. Check what's new
# zypper lu

4. Update
# zypper up -l

5. Dist update
# zypper dup -l

If in 4. or 5. packages are to be removed, I will investigate
a. Will it be replaced by something newer/better
b. Do I need it for something

If I want to keep it (for whatever reason), I either lock it or make a backup
and re-install it after I'm done updating

e.g. I am *very* *very* *very* fond on keeping Opera-12.16 running,
even though I have all alternatives available:

# rpm -qa | grep -i -e opera -e vivaldi -e chromium -e google-chr -e moon -e
epiph -e konqer -e lynx -e links -e w3m -e firef -e midori -e otter -e pzilla |
sort
chromium-62.0.3202.94-2.1.x86_64
chromium-plugin-widevinecdm-1.4.8.1029-1.1.x86_64
elinks-0.11.996-2.7.x86_64
epiphany-3.26.2-1.1.x86_64
epiphany-branding-openSUSE-42.1-7.8.noarch
epiphany-lang-3.26.2-1.1.noarch
gnome-shell-search-provider-epiphany-3.26.2-1.1.x86_64
google-chrome-beta-63.0.3239.18-1.x86_64
google-chrome-stable-61.0.3163.100-1.x86_64
google-chrome-unstable-64.0.3251.0-1.x86_64
libmidori-core1-0.5.11-4.1.x86_64
libplotter2-2.6-27.4.x86_64
links-2.14-2.2.x86_64
lynx-2.8.9~dev.16-1.2.x86_64
midori-0.5.11-4.1.x86_64
midori-branding-openSUSE-4.12.0-4.3.noarch
midori-lang-0.5.11-4.1.noarch
MozillaFirefox-57.0-1.1.x86_64
MozillaFirefox-branding-openSUSE-45-3.2.x86_64
MozillaFirefox-translations-common-57.0-1.1.x86_64
newmoon-27.6.2-1.2.x86_64
opera-12.16-1860.x86_64
opera-beta-50.0.2762.18-0.x86_64
opera-developer-51.0.2791.0-0.x86_64
otter-browser-0.9.92-1.1.x86_64
qupzilla-2.2.1-1.2.x86_64
qupzilla-gnome-keyring-2.2.1-1.2.x86_64
qupzilla-kwallet-2.2.1-1.2.x86_64
vivaldi-snapshot-1.14.1030.3-1.x86_64
w3m-0.5.3.git20161120-1.5.x86_64
w3m-inline-image-0.5.3.git20161120-1.5.x86_64

Cheers
Dominique

--
H.Merijn Brand http://tux.nl Perl Monger http://amsterdam.pm.org/
using perl5.00307 .. 5.27 porting perl5 on HP-UX, AIX, and openSUSE
http://mirrors.develooper.com/hpux/ http://www.test-smoke.org/
http://qa.perl.org http://www.goldmark.org/jeff/stupid-disclaimers/
< Previous Next >