Mailinglist Archive: opensuse-factory (454 mails)

< Previous Next >
Re: [opensuse-factory] openssl dependency problems with snapshot 20171129
On Fri, 01 Dec 2017 08:36:15 +0100, Dominique Leuenberger / DimStar
<dimstar@xxxxxxxxxxxx> wrote:

Hi all,

On Thu, 2017-11-30 at 22:33 +0200, Stratos Zolotas wrote:
Hello,

I'm getting the following result with the latest snapshot and I can't
find an obvious solution. Any possible solution results on
deinstallation of multiple packages and multiple dependency
problems..

sudo zypper dup --no-allow-vendor-change
Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you
continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
2 Problems:
Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 conflicts with
libopenssl-devel > 1.0.2m provided by
libopenssl-devel-1.1.0g-1.1.noarch
Problem: openssl-1.1.0g-1.1.noarch requires openssl-1_1_0 = 1.1.0g,
but this requirement cannot be provided

Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 conflicts with
libopenssl-devel > 1.0.2m provided by
libopenssl-devel-1.1.0g-1.1.noarch
Solution 1: deinstallation of libopenssl-1_0_0-devel-1.0.2m-
1.1.x86_64
Solution 2: deinstallation of libopenssl-devel-1.0.2m-1.1.noarch
Solution 3: keep obsolete libopenssl-devel-1.0.2m-1.1.noarch

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/c] (c):

Seems we missed an obsoletes for the -devel package. The best answer
depends on why you even have libopenssl-devel installed on your system.
The 'Tumbleweed default' should be to 'deinstall libopenssl-1_0_0-
devel', which would then pull in libopenssl-1_1_0-devel instead.

Packages that depend on 1.0.2m:

# zypper rm libopenssl-devel-1.0.2m-1.1.noarch
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 9 packages are going to be REMOVED:
libetpan-devel libksane-devel libmysqlclient-devel libopenssl-devel
libserf-devel libssh2-devel net-snmp-devel
sane-backends-devel wvstreams-devel

9 packages to remove.
After the operation, 13.0 MiB will be freed.
Continue? [y/n/...? shows all options] (y):

Packages that block moving forward:

# zypper up libopenssl-devel
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 conflicts with
libopenssl-devel > 1.0.2m provided by libopenssl-devel-1.1.0g-1.1.noarch
Solution 1: Following actions will be done:
deinstallation of libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64
deinstallation of libqt4-devel-4.8.7-9.1.x86_64
deinstallation of phonon-devel-4.9.0-1.7.x86_64
deinstallation of gstreamer-plugins-qt-devel-1.2.0-7.2.x86_64
deinstallation of libQtWebKit-devel-4.8.7+2.3.4-3.5.x86_64
deinstallation of libakonadiprotocolinternals-devel-1.13.0-10.2.x86_64
deinstallation of libattica-devel-0.4.2-5.9.x86_64
deinstallation of libavahi-qt4-devel-0.6.32-4.1.x86_64
deinstallation of libpolkit-qt-1-devel-0.112.0-1.7.x86_64
deinstallation of libpoppler-qt4-devel-0.59.0-2.1.x86_64
deinstallation of libqimageblitz-devel-0.0.6-13.9.x86_64
deinstallation of libqjson-devel-0.8.1-9.10.x86_64
Solution 2: do not install libopenssl-devel-1.1.0g-1.1.noarch

Choose from above solutions by number or cancel [1/2/c] (c):

Being me test/development box, I'd rather not de-install other packages

Depending of what kind of software you're building locally, you might
want to switch between the provided openssl-1_x_0-devel packages.

Cheers,
Dominique


--
H.Merijn Brand http://tux.nl Perl Monger http://amsterdam.pm.org/
using perl5.00307 .. 5.27 porting perl5 on HP-UX, AIX, and openSUSE
http://mirrors.develooper.com/hpux/ http://www.test-smoke.org/
http://qa.perl.org http://www.goldmark.org/jeff/stupid-disclaimers/
< Previous Next >