Mailinglist Archive: opensuse-factory (824 mails)

< Previous Next >
[opensuse-factory] Re: ffmpeg and h264 (again) using vaapi
  • From: "Matwey V. Kornilov" <matwey.kornilov@xxxxxxxxx>
  • Date: Sun, 29 Oct 2017 11:45:06 +0300
  • Message-id: <ot44ef$5h3$1@blaine.gmane.org>
29.10.2017 10:07, Dave Plater пишет:


On 28/10/2017 22:04, Matwey V. Kornilov wrote:
Hello,

I am running Leap 42.3. It is stated that H.264 is disabled in ffmpeg in
opensuse due to legal reasons:

https://en.opensuse.org/SDB:Firefox_MP4/H.264_Video_Support

However, some hardware (for instance Intel Quick Sync Video) have
ability to hardware h264 decoding. And this currently works for me out
of the box via gstreamer-vaapi. So, I think hardware h264 decoding is
allowed in opensuse.

At the same time, I've failed to achive this for ffmpeg. I am tring to
follow this guide: https://trac.ffmpeg.org/wiki/Hardware/VAAPI

But every time I see the following: "This build of ffmpeg does not
include a "h264" decoder needed for input stream #0:0."
Well, is it possible to force ffmpeg use vaapi by default to decode h264
in hardware?

Unfortunately ffmpeg doesn't have vaapi decoders, only encoders and
vaapi is enabled in all builds. There are no options for vaapi decoders
in configure only --enable-vaapi. This is from ffmpeg-3.4.

That is sad. Wouldn't be it cool to support H264 out of the box via
VAAPI (on some machines) without legal issues?


Dave P


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups