Mailinglist Archive: opensuse-factory (826 mails)

< Previous Next >
Re: [opensuse-factory] rpmlint 1.10 about to enter openSUSE Factory
Hi Richard,

2017-10-10 12:04 GMT+02:00 Richard Biener <rguenther@xxxxxxx>:

is needed. This lets the rpm-dependency magic add a proper
file-depends on /usr/bin/python2, pulling in python-base if it isn't
installed already.
Huh, why not fix RPM instead?

What would the fix look like? I know artificial intelligence is at the
peak of the hype cycle right now, but I haven't seen support for it
added to rpm yet ;-)

The only "valid" solution would be to suppress a auto-depends on
/usr/bin/env, which is sort of wrong as well (because if a script
really uses it, it needs to be there so the dependency is correct).
And for the 2nd parameter: env evaluates your $PATH, so there is no
way for rpm to figure out which interpreter you meant because it
doesn"t know the setting of $PATH at the time the script got executed.
and it would be just as bad it "guessing" wrong than not guessing at
all.

Greetings,
Dirk
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >