Mailinglist Archive: opensuse-factory (826 mails)

< Previous Next >
Aw: Re: [opensuse-factory] Re: SUSE Studio Express questions
  • From: "Axel Braun" <Axel.Braun@xxxxxx>
  • Date: Mon, 9 Oct 2017 20:58:08 +0200
  • Message-id: <trinity-9a6b9c53-ff10-41c6-8f1f-499a37612974-1507575487944@3c-app-gmx-bs19>


Gesendet: Montag, 09. Oktober 2017 um 18:12 Uhr
Von: "Roger Oberholtzer" <roger.oberholtzer@xxxxxxxxx>
An: "Andreas Jaeger" <aj@xxxxxxxx>
Cc: "Jim Henderson" <hendersj@xxxxxxxxx>, opensuse-factory
<opensuse-factory@xxxxxxxxxxxx>
Betreff: Re: [opensuse-factory] Re: SUSE Studio Express questions

On Mon, Oct 9, 2017 at 9:32 AM, Andreas Jaeger <aj@xxxxxxxx> wrote:
On 2017-10-09 09:07, Roger Oberholtzer wrote:
On Fri, Oct 6, 2017 at 2:09 PM, Andreas Jaeger <aj@xxxxxxxx> wrote:
On 2017-09-26 12:34, Roger Oberholtzer wrote:
On Mon, Sep 25, 2017 at 8:33 PM, Jim Henderson <hendersj@xxxxxxxxx>
wrote:

It would be great if one could import a kiwi project that one
currently runs on a local computer. Not just one set up in Studio.

You should be able to add kiwi files that you have locally, there's
nothing magic here. What is not working for you?

I have not figured out the general work flow. I can choose some
pre-defined things to build. So I am guessing one chooses one of
those, and then changes files as needed?

I guess I need to play with it a bit to see what I can do. An "Import
local KIWI spec" would make sense. Of course, I only have a handful of
these. So if I get the steps sorted out I can do things by hand. I'm
okay with that. As long as I know what makes sense to change.


See also
http://openbuildservice.org/2017/09/27/suse-studio-express/

I've added my kiwi files, but I get a error that nothing defines any
of the packages I want. I know that if I specify the repository wrong
I get an error. But I don't get that kind of error.

https://build.opensuse.org/package/show/home:rogeroberholtzer/rsl-oem-42.3

This pretty much works as a native build on my Leap 42.3. I expect it
would get further along. I'm sure I'm just blind.

There are some error messages regarding 'have choice of...' - fix them by
adding the respective package to your build, then try again

I cc opensuse-packaging, we should follow-up there.

Cheers
Axel
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >