Mailinglist Archive: opensuse-factory (826 mails)

< Previous Next >
Re: [opensuse-factory] Tumbleweed snapshot 20171007: pulseaudio issues
  • From: Peter Suetterlin <P.Suetterlin@xxxxxxxxxxxx>
  • Date: Mon, 9 Oct 2017 16:22:56 +0100
  • Message-id: <20171009152256.mhlaftqzwo4sreg4@woodstock.pitnet>

I just did the update to 20171007.

After the reboot, pulsaudio no longer recognizes the soundcard of my docking
station. I have a Lenovo T460p with one of the 'real' docking stations (i.e.,
not USB connected).

So far, when I placed the laptop to the dock, sound would switch to the card
in the dock and play via the there connected external speaker system.

Not anymore. Nothing suggests the card is recognized, and neither does it
automatically switch, nor is it possible manually (tried KDE volume and
pavucontrol).

I first thought it was the pulse update to 11.1 from 20170924, but I had
rebooted Oct 2, and AFAIR it had still worked with it.

If I grep the journalctl output for pulse I can see two suspicious things:

When shutting down after the update I see a line

Oct 09 15:24:04 woodstock.pitnet pulseaudio[2233]: [pulseaudio]
module-x11-publish.c: PulseAudio information vanished from X11!

And with the boot if the updated system I see

Oct 09 15:40:10 woodstock.pitnet pulseaudio[4408]: [pulseaudio]
backend-ofono.c: Failed to register as a handsfree audio agent with ofono:
org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided
by any .service files

I have not seen this message with the old system, though I unfortunately I
don't have too many old logs (limits) to properly check :(

Has anyone else seen similar issues with (one of) the latest update(s), or
suggestions how to narrow it down?
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups