Mailinglist Archive: opensuse-factory (826 mails)

< Previous Next >
[opensuse-factory] exim problem after installing 20171007
Problem: exim-4.86.2-4.2.x86_64 requires libldap-2.4.so.2()(64bit), but this
requirement cannot be provided
deleted providers: libldap-2_4-2-2.4.45-26.2.x86_64
Solution 1: deinstallation of exim-4.86.2-4.2.x86_64
Solution 2: keep obsolete libldap-2_4-2-2.4.45-26.2.x86_64
Solution 3: break exim-4.86.2-4.2.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c):

Choosing solution 3 certainly does break exim - it won't start.

So I have reverted to libldap-2_4-2-2.4.45-26.2.x86_64 and locked it.

What is happening here?

$ rpm -qpl libldap-2_4-2-2.4.45-26.2.x86_64.rpm
/usr/lib64/liblber-2.4.so.2
/usr/lib64/liblber-2.4.so.2.10.8
/usr/lib64/libldap-2.4.so.2
/usr/lib64/libldap-2.4.so.2.10.8
/usr/lib64/libldap_r-2.4.so.2
/usr/lib64/libldap_r-2.4.so.2.10.8

$ rpm -qpl libldap-2_4-2-2.4.45-27.1.x86_64.rpm
/usr/lib64/liblber-2.4.so.2
/usr/lib64/liblber-2.4.so.2.10.8
/usr/lib64/libldap_r-2.4.so.2
/usr/lib64/libldap_r-2.4.so.2.10.8


/usr/lib64/libldap-2.4.so.2 and /usr/lib64/libldap-2.4.so.2.10.8 are
no longer present.


--
============================
Roger Whittaker
roger@xxxxxxxxxxxxxxxxx
============================
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >