Mailinglist Archive: opensuse-factory (826 mails)

< Previous Next >
[opensuse-factory] perl provides broken [was: New Tumbleweed snapshot 20171003 released!]
On 10/05/2017, 09:00 PM, Dominique Leuenberger wrote:
perl (5.24.1 -> 5.26.1)
perl-Crypt-SSLeay
perl-Encode-HanExtra
perl-FileHandle-Unget
perl-Module-Signature
perl-Task-Weaken
perl-Term-ReadKey (2.32 -> 2.37)
perl-ldap (0.64 -> 0.65)

Something is broken with perl provides, it seems:

BuildRequires: perl(Locale::TextDomain)

installs perl-Text-Unidecode-1.30-9.9, which does *not* contain the
module. perl-libintl-perl contains that module, but that one is not
installed via the BuildRequires.

So there is a difference in these two wrt to build success/failure of
some packages:
BuildRequires: perl(Locale::TextDomain)
BuildRequires: perl-libintl-perl

Ideas?

thanks,
--
js
suse labs
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups