Mailinglist Archive: opensuse-factory (826 mails)

< Previous Next >
Re: [opensuse-factory] Cups behaviour in actual TW
  • From: Axel Braun <axel.braun@xxxxxx>
  • Date: Mon, 02 Oct 2017 15:21:42 +0200
  • Message-id: <3835489.vEfPkRr6tV@t520.axxite.internal>
Am Montag, 2. Oktober 2017, 14:24:14 CEST schrieb Antonio Larrosa:
On 10/02/2017 08:04 AM, Bruno Friedmann wrote:
On dimanche, 1 octobre 2017 19.37:11 h CEST Axel Braun wrote:
Hi,
I have to admit that I'm not printing that much...so the issue may
already
be older

In current TW there is CUPS 2.2.3 installed. I originally had only one
network printer (Queue: MFC9340CDW) defined, using a lpd connection to
lpd:// 192.168.1.103/binary_p1
Works properly.

Now a second printer shows up - same device, different name
(Brother_MFC_9340CDW) connecting to
ipp://BRW3C77E658BC0F.local:631/ipp/print
This one is probably auto-detected, but not working properly (test page
is
empty)

To make things worse, when printing from KDE, KDE print dialog shows a
third Queue "Brother MFC-9340CDW", which is working neither. From the
KDE-system settings, only the two queues are shown that are in Cups as
well

[...]

If you do
export QT_DISABLE_PRINTER_DISCOVERY=1
on konsole before running the KDE/Qt application that tries to print, it
should disable the discovery and use the printer configuration as usual.

You can of course also set QT_DISABLE_PRINTER_DISCOVERY=1 in
/etc/environment or in ~/.profile to fix the option for all applications.

Can you (both) try that and see if that fixes the problems?

After logging off and on again, KDE print dialog now only shows the two queues
as visible in cups.

Maybe we make this a default setting?

Thanks
Axel

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups