Mailinglist Archive: opensuse-factory (826 mails)

< Previous Next >
[opensuse-factory] cifs mount parameters no longer work, SOLVED
I have used the following fstab entry for quite some time but a recent
update, since 0923, it fails and I cannot determine the fail point. I
have removed one parameter at a time but still cannot mount the partition.

<fstab>
//192.168.1.14/C-Share/ /home/paka/cifs cifs
//credentials=/root/.smbcredentials,guest,nofail,_netdev,iocharset=utf8,sec=ntlm,uid=1000,gid=100,file_mode=0777,dir_mode=0777
//0 0
</fstab>

</root/.smbcredentials>
username=XXXXXXX
password=XXXXXXX
</root/.smbcredentials>

the failure msg:
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

from /var/log/messages:
No dialect specified on mount. Default has changed to a more secure
dialect, SMB3 (vers=3.0), from CIFS (SMB1). To use the less secure SMB1
dialect to access old servers which do not support SMB3 specify vers=1.0
on mount. For somewhat newer servers such as Windows 7 try vers=2.1.
CIFS VFS: Unable to select appropriate authentication method!
CIFS VFS: Send error in SessSetup = -22
CIFS VFS: cifs_mount failed w/return code = -22


after much searching, the answer was simple:
remove "sec=ntml" from fstab entry

research indicates a kernel change may be responsible and may relate to
"plain text passwords"

works now after removing sec=

--
(paka)Patrick Shanahan Plainfield, Indiana, USA @ptilopteri
http://en.opensuse.org openSUSE Community Member facebook/ptilopteri
Registered Linux User #207535 @ http://linuxcounter.net
Photos: http://wahoo.no-ip.org/piwigo paka @ IRCnet freenode
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups