Mailinglist Archive: opensuse-factory (421 mails)

< Previous Next >
[opensuse-factory] Can I remove locks in TW
Hello to the list,

in March I asked the list with the topic
"up vs dup with commerical intel compilers installed"

Then I locked my intel-rpms (commercial Intel Parallel Studio) but
later found that I shall better use a local repository of rpms.

Now I want to do another dup. I did zypper locks and removed all locks from packages containing the keyword 'intel' (apparently wildecards don't work).

I still have

sudo zypper locks

# | Name | Type | Repository
---+--------------------------------+---------+-----------
1 | openSUSE | product | (any)
2 | libguilereadline-v-17-17 | package | (any)
3 | Mesa-32bit | package | (any)
4 | gstreamer-plugins-libav | package | (any)
5 | Mesa-dri-nouveau | package | (any)
6 | guile-modules-2_0 | package | (any)
7 | Mesa | package | (any)
8 | dleyna-server | package | (any)
9 | guile1 | package | (any)
10 | kernel-default | package | (any)
11 | kernel-firmware | package | (any)
12 | libdrm-devel | package | (any)
13 | libguile-srfi-srfi-1-v-3-3 | package | (any)
14 | libguile-srfi-srfi-13-14-v-3-3 | package | (any)
15 | libguile-srfi-srfi-4-v-3-3 | package | (any)
16 | libguile-srfi-srfi-60-v-2-2 | package | (any)
17 | libguile17 | package | (any)
18 | guile | package | (any)
19 | libpsm2-2 | package | (any)
20 | libguile-2_0-22 | package | (any)
21 | mingw64-runtime | package | (any)
22 | openSUSE-release | package | (any)
23 | texlive-cleveref | package | (any)


An these locks prevent zypper dup. I don't know where these locks come from. Is this normal? I already removed libdrm_intel1 and ibus but fear to continue as I have no glue what I'm doing by that :(

sudo zypper dup
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
2 Problems:
Problem: libdrm-devel-2.4.80-1.1.x86_64 requires libdrm2 = 2.4.80, but this requirement cannot be provided
Problem: libdrm-devel-2.4.80-1.1.x86_64 requires libdrm_amdgpu1 = 2.4.80, but this requirement cannot be provided

Problem: libdrm-devel-2.4.80-1.1.x86_64 requires libdrm2 = 2.4.80, but this requirement cannot be provided
deleted providers: libdrm2-2.4.80-1.1.x86_64
Solution 1: keep obsolete libdrm2-2.4.80-1.1.x86_64
Solution 2: remove lock to allow removal of libdrm-devel-2.4.80-1.1.x86_64
Solution 3: break libdrm-devel-2.4.80-1.1.x86_64 by ignoring some of its dependencies

I you tell me it is save to remove all locks I'm happy to do this :)

Thanks for your help and please let me know if a forum is a more appropriate place.

Fabian
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >