Mailinglist Archive: opensuse-factory (331 mails)

< Previous Next >
Re: [opensuse-factory] TW auto suspend on low battery level
Il 06/09/2017 05:11, Stefan Seyfried ha scritto:
On 04.09.2017 20:17, Marco Calistri wrote:
But I'm sure to not to be the only one suffering with a non working
suspend/hibernate on laptop here on Tumbleweed (tested on Gnome, XFCE
and Cinnamon)

xfce4-power-manager low battery suspend definitely works for me here.

I know it, because I hate it when this happens, and because you can only set
it to "1% left", not "0% left". And 1%
would still run for many minutes ;-)

In your case, it not working in all DEs is more likely a problem with the
battery driver or such, not sending events on
capacity change and thus needing polling which might be not working correctly
(I have no idea if this might be broken or
not, my batteries are sending proper events)

Thanks for your feedback Stefan,

I tried to adjust the power-managers of all the DE I've installed on my
TW and no one worked.

My battery is old and it lost much of its factory charge but suspend
works quite well on Windows 10 which I use in dual boot with TW and also
from the changes I see into the files under
/sys/class/power_supply/BAT1/ I understand that some sort of events are
being still produced.

In any case now I'm satisfied with my workaround the abrupt powering off
is not healthy for HDD and batteries so to me this was an urgent problem
to resolve.

Cheers,

--
Marco Calistri
< Previous Next >
Follow Ups