Mailinglist Archive: opensuse-factory (331 mails)

< Previous Next >
Re: [opensuse-factory] OpenJDK 1.8.0/SeaMonkey 2.48 incompatibility on Leap 42.3
Dear Wolfgang,

On Sun, 3 Sep 2017 08:08:04 +0200, Wolfgang Rosenauer
<wolfgang@xxxxxxxxxxxxx> wrote:
Am 31.08.2017 um 14:54 schrieb Tristan Miller:
It seems it is not possible to install the latest official release
of OpenJDK (1.8.0, from the update repository) together with the
latest official release of SeaMonkey (2.48, from the mozilla
repository) on Leap 42.3.

Zypper and YaST tell me that this is because
seamonkey-2.48-1.3.x86_64 requires mozilla-nspr >= 4.15, whereas
java-1_8_0-openjdk-headless-1.8.0.144-13.3.x86_64 requires
mozilla-nss = 3.28.5.

Is this really the correct message? I do not see a correlation between
mozilla-nspr and mozilla-nss like described above.

No, sorry, it's not the correct message. I was trying to summarize
what was actually a complicated set of conflicts. Looks like I didn't
notice the difference between "mozilla-nspr" and "mozilla-nss".

The actual conflict message from trying to install SeaMonkey 2.48 is as
follows:

seamonkey-2.48-1.3.x86_64 requires mozilla-nspr >= 4.15, but this
requirement cannot be provided uninstallable providers:
mozilla-nspr-4.15-1.1.i586[mozilla]
mozilla-nspr-4.15-1.1.x86_64[mozilla] [ ] do not install
seamonkey-2.48-1.3.x86_64

[ ] break seamonkey-2.48-1.3.x86_64 by ignoring some of its
dependencies

[ ] Following actions will be done:
install mozilla-nspr-4.15-1.1.x86_64 (with vendor change)
openSUSE --> obs://build.opensuse.org/mozilla
install mozilla-nspr-devel-4.15-1.1.x86_64 (with vendor change)
openSUSE --> obs://build.opensuse.org/mozilla
install mozilla-nss-devel-3.31-1.1.x86_64 (with vendor change)
openSUSE --> obs://build.opensuse.org/mozilla
deinstallation of java-1_8_0-openjdk-headless-1.8.0.144-13.3.x86_64
deinstallation of java-1_8_0-openjdk-1.8.0.144-13.3.x86_64
deinstallation of java-1_8_0-openjdk-devel-1.8.0.144-13.3.x86_64


If the vendor change is accepted, then a second conflict arises:

seamonkey-2.48-1.3.x86_64 requires mozilla-nss >= 3.31, but this
requirement cannot be provided uninstallable providers:
mozilla-nss-3.31-1.1.i586[mozilla] mozilla-nss-3.31-1.1.x86_64[mozilla]
[ ] break seamonkey-2.48-1.3.x86_64 by ignoring some of its
dependencies

[ ] Following actions will be done:
do not install mozilla-nss-devel-3.31-1.1.x86_64
do not install seamonkey-2.48-1.3.x86_64
[ ] Following actions will be done:
do not install seamonkey-2.48-1.3.x86_64
do not install mozilla-nss-devel-3.31-1.1.x86_64
[ ] install mozilla-nss-3.31-1.1.x86_64 (with vendor change)
openSUSE --> obs://build.opensuse.org/mozilla


Trying to switch all packages to the "mozilla" repository results in an
even more complicated set of conflicts. No matter what resolution
path is followed, it doesn't seem possible to have both SeaMonkey 2.48
and OpenJDK 1.8.0 installed at the same time.

As Felix mentioned, there is no problem running the 64-bit "contrib"
build from the SeaMonkey website.

I think what you see is the outfall of
https://bugzilla.suse.com/show_bug.cgi?id=1026102

I can't pretend to understand the entirety of that issue, but I'll take
your word for it that it's the cause.

In the current situation you can only ignore the Java<->NSS
dependency and update NSS as required by Seamonkey (or any other
package from mozilla). Your probability that Java still works is 99%
anyway.

OK, I'll give it a try. In the worst case, I can revert to SeaMonkey
2.46. (I can't live without OpenJDK 1.8.0 as I need to develop in Java
8.)

Regards,
Tristan

--
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Tristan Miller
Free Software developer, ferret herder, logologist
https://logological.org/
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
< Previous Next >
References