Mailinglist Archive: opensuse-factory (378 mails)

< Previous Next >
Re: [opensuse-factory] OpenJDK 1.8.0/SeaMonkey 2.48 incompatibility on Leap 42.3


On 31/08/17 22:24, Tristan Miller wrote:
Dear all,

It seems it is not possible to install the latest official release of
OpenJDK (1.8.0, from the update repository) together with the latest
official release of SeaMonkey (2.48, from the mozilla repository) on
Leap 42.3.

Zypper and YaST tell me that this is because seamonkey-2.48-1.3.x86_64
requires mozilla-nspr >= 4.15, whereas
java-1_8_0-openjdk-headless-1.8.0.144-13.3.x86_64 requires
mozilla-nss = 3.28.5.

This incompatibility does not seem to exist on Tumbleweed, where both
packages live together in peace and harmony. This leads me to believe
it's a packaging problem. Where would be the best place to report this?

Regards,
Tristan


This is likely not a packaging bug, nor a bug at all, its a design
decision we have taken with Leap to stay at a fixed version of many
software components for stability, as such its not going to always be
possible to install the latest versions of software like seamonkey on
leap as we don't meet there version requirements for dependencies.

In openSUSE we only give you 2 options, run sometimes older software
that was tested together with other software from a similar time to
create a "Stable" Distro ie Leap, or you can run the latest of
everything being tumbleweed (which is mostly quite stable because most
developers of most software run the latest everything anyway).

We don't officially support a middle position ie Leap with some newer
apps because its much harder due to issues like the one you are seeing.

--

Simon Lees (Simotek) http://simotek.net

Emergency Update Team keybase.io/simotek
SUSE Linux Adelaide Australia, UTC+10:30
GPG Fingerprint: 5B87 DB9D 88DC F606 E489 CEC5 0922 C246 02F0 014B

< Previous Next >
Follow Ups