Mailinglist Archive: opensuse-factory (340 mails)

< Previous Next >
Re: [opensuse-factory] Tumbleweed - Review of the week 201/35
  • From: Neal Gompa <ngompa13@xxxxxxxxx>
  • Date: Fri, 1 Sep 2017 11:26:49 -0400
  • Message-id: <CAEg-Je-deiZdMyFEWPhUbgL=6VY6sg8YhpRHD_B3P+WQLD9x+w@mail.gmail.com>
On Fri, Sep 1, 2017 at 11:20 AM, Dominique Leuenberger / DimStar
<dimstar@xxxxxxxxxxxx> wrote:
On Fri, 2017-09-01 at 17:17 +0200, Jan Engelhardt wrote:
On Friday 2017-09-01 16:59, Dominique Leuenberger / DimStar wrote:

with the introduction of the package
dnf, that uses some of the new rpm boolean dependency operators
(new
since rpm 4.13), we ended up having metadata n the repository that
is
well understood by Tumbleweed systems, but not by any system one
might
want to upgrade to Tumbleweed (Think Leap 42.x). The final solution
will be to finish the migration to the new product-builder, and
thus
using pure rpm-md repositories

Does that mean the "yast2" repository type (for zypper/repos.d/*)
will go away?

Indeed - the new product builder will only provide pure rpm-md repos.

The repo structure on download.o.o of course will stay as we have it:
download.opensuse.org/tumbleweed/repo/oss will continue to be the
correct repo, but it's type will change from yast2 to rpm-md; libzypp
was already though to handle this change (and treating the type=
parameter in the .repo file as help, but re-evaluate if yast2 type is
no longer available there).


This has been broken in libzypp since openSUSE 13.2. It returns
`type=NONE` and can't do anything with the repo in that circumstance.

--
真実はいつも一つ!/ Always, there's only one truth!
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >