Mailinglist Archive: opensuse-factory (649 mails)

< Previous Next >
Re: [opensuse-factory] [Leap 42.3] VirtualBox does not start up
On 08/14/2017 12:23 PM, Roman Bysh wrote:
On 14/08/17 03:20 PM, Roman Bysh wrote:
On 14/08/17 02:47 PM, Manfred Hollstein wrote:
> On Mon, 14 Aug 2017, 20:26:42 +0200, Roman Bysh wrote:
> > On 14/08/17 02:21 PM, Manfred Hollstein wrote:
> >> [...]
> >> What does the following show on your system:
> >>
> >> rpm -V virtualbox virtualbox-host-kmp-default virtualbox-qt
> >>
> >> Please run the command as user root. The "Tip!" above might actually
> >> help to resurrect the situation for you:
> >>
> >> zypper in --force virtualbox virtualbox-host-kmp-default virtualbox-qt
> >>
> >> Afterwards you could re-run the "rpm -V ..." command above and compare
> >> outputs.
> >>
> >> If you suspect that some permissions are wrong for some programs, you
> >> can also check for that (again as "root"):
> >>
> >> chkstat --system
> >>
> >> If this indicates something *is* wrong, you can even set the permissions
> >> to their proper value (also as "root"):
> >>
> >> chkstat --system --set
> >>
> >> HTH, cheers.
> >>
> >> l8er
> >> manfred
> >>
> > rpm -V virtualbox virtualbox-host-kmp-default virtualbox-qt
> > /usr/lib/virtualbox/VBoxNetDHCP should be root:vboxusers 4750. (wrong
permissions 0750)
> > /usr/lib/virtualbox/VBoxNetAdpCtl should be root:vboxusers 4750. (wrong
permissions 0750)
> > /usr/lib/virtualbox/VBoxHeadless should be root:vboxusers 4750. (wrong
permissions 0750)
> > /usr/lib/virtualbox/VBoxSDL should be root:vboxusers 4750. (wrong
permissions 0750)
> > /usr/lib/virtualbox/VirtualBox should be root:vboxusers 4750. (wrong
permissions 0750)
>
> Thx. This indeed appears to be wrong. Do you have a group "vboxusers" on
> your system, and are you (your user ID) member of that group? You can
> check that by running the following command as "root":
>
> grep vboxusers /etc/group
>
> If the output shows something like
>
> vboxusers:x:SOMENUMBER:YOURUSERNAME
>
> you're OK. If the group exists, but you're not member of it, you can fix
> that by running the following command as "root":
>
> usermod -a -G vboxusers YOURUSERNAME
>
> In any case, the permissions appear to be wrong on your system, so I'd
> suggest you either re-install the packages ("zypper in ..." above), or
> get the permissions fixed for the already installed packages ("chkstat
> --system --set").
>
> Once this has been done, you should logout from your desktop session and
> login again. If this still doesn't help, you should send us the
> following:
>
> id # run as your normal user, not "root", not via "sudo"
> chkstat --system # run this as "root"
>
> Cheers.
>
> l8er
> manfred
>
Looks like the comman "chkstat --system --set" fixed the problem.

Thanks Manfred


Cheers!

Roman

Oops. Forgot the "d" :-)

Cheers to Roman for first class assistance!

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >