Mailinglist Archive: opensuse-factory (649 mails)

< Previous Next >
Re: [opensuse-factory] Intel GPU hangs


On 31/07/2017 22:18, Linux Kamarada wrote:
2017-07-25 3:45 GMT-03:00 Felix Miata <mrmazda@xxxxxxxxxxxxx>:
Dave Plater composed on 2017-07-25 08:25 (UTC+0200):

Takashi Iwai wrote:

If you're using an old Intel graphics chip, could you try to uninstall
drm-kmp-default package once, reboot and retest?

I'm not sure what old Intel graphics relates to. I have an "Intel(R)
Core(TM) i3-2120 CPU @ 3.30GHz" and after updating to 42.3 from 42.2 I
have frequent intermittent gpu hangs unless I boot with nomodeset.
https://bugzilla.novell.com/show_bug.cgi?id=1050256

https://bugzilla.opensuse.org/show_bug.cgi?id=1050256 for openSUSE users ;-)

Ouch!

i3-2120 (8086:0102 aka Sandy Bridge) was introduced >6 years ago. I have
slightly older working fine with Plasma (but only in TW: all my 42.3 use TDE or
KDE3.)

You could try uninstalling xf86-video-intel. That should cause Xorg to run on
Xorg's integrated modesetting driver, which all my Intel machines that aren't
too old for it to support are happily using.
--
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx


Today I faced the same problem at work on a machine that I just
upgraded from 42.2 to 42.3.

From times to times, the window manager was crashing and restarting,
until the session was finally finished and the login screen presented,
making impossible to use any desktop environment (now I use GNOME, but
I tried GNOME Classic and Plasma 5 and the same happened).

I have an Intel(R) Core(TM) i5-4460 CPU @ 3.20GHz, according to YaST.

Searching the mailing list, I came to this thread.

First, I tried uninstalling the xf86-video-intel package, actually I
uninstalled xf86-video-* packages, leaving only xf86-video-vesa and
xf86-video-fbdev (I believe those are the generic drivers, am I
right?) and then rebooted. Nothing changed: crashes still happened.

Then, I uninstalled the drm-kmp-default package and rebooted. Until
now (uptime = 25 minutes), no crashes with GNOME. I'm going home now,
tomorrow I will watch and see if the problem has really been solved.

I'm not sure if I'm using Xorg's integrated modesetting driver because
if I try to find what video driver is in use on my system (following
instructions I found here: https://askubuntu.com/a/254877/560233), I
retrieve the following:

# lspci -nnk | grep -i vga -A3
00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon
E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
[8086:0412] (rev 06)
Subsystem: Gigabyte Technology Co., Ltd Device [1458:d000]
Kernel driver in use: i915
Kernel modules: i915

Am I still using the Intel driver? As I uninstalled the
xf86-video-intel package, shouldn't it have been gone?

Thank you in advance,


Antonio
The Linux Kamarada Project
http://kamarada.github.io/

Uninstalling drm-kmp-default or booting with nomodeset is a temporary work around, an updated drm-kmp-default is in the pipeline but an installation conflict has to be fixed. I also found, in my case, that the crash didn't occur in xfce. It's very memory sensitive, the less ram you have in your machine the more likely that a gpu hang occurs. You should add yourself to the bug, the more reporters the better the bug fix.
Best regards
Dave P
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages