Mailinglist Archive: opensuse-factory (649 mails)

< Previous Next >
[opensuse-factory] prosody fails to start since updating lua51-luasocket
Recently the package "lua51-luasocket" changed from being an openSUSE
package to only being available in
obs://build.opensuse.org/devel:languages:lua

Here is zypper's message:
Problem: Problem mit installiertem Paket
lua51-luasocket-3.0~rc1+git20140716-2.2.x86_64
Lösung 1: lua51-luasocket-3.0~rc1+git20170515.5a17f79-6.1.x86_64
installieren (mit Anbieterwechsel)
openSUSE --> obs://build.opensuse.org/devel:languages:lua

I accepted this change, but since then, prosody fails to start, showing
this message:
$ sudo prosodyctl start
lua5.1: /usr/bin/prosodyctl:428: attempt to index global 'socket' (a
nil value)
stack traceback:
/usr/bin/prosodyctl:428: in function '?'
/usr/bin/prosodyctl:861: in main chunk
[C]: ?

There is a similar bug for Debian too, including a possible fix:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=855158
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups