Mailinglist Archive: opensuse-factory (914 mails)

< Previous Next >
Re: [opensuse-factory] Running konsole remotely
On Wed, Jun 28, 2017 at 06:25:38PM +0200, Wolfgang Bauer wrote:
Am Mittwoch, 28. Juni 2017, 10:51:08 schrieb Roger Whittaker:
With recent Tumbleweed versions I find that a new konsole run this way
will become totally unresponsive for about 10 seconds the first time
that I do a tab complete in bash inside it.

Are you sure it is about 10 seconds, and not 25s? ;-)

Well - I didn't have a stopwatch...

This sounds like https://bugs.kde.org/show_bug.cgi?id=380974.

Yes.

In short, that 25s delay happens for every KDE application that tries to
display a notification when no notifications service is running (or it cannot
be found because you run the application as different user or via ssh).
It's caused by changes in Plasma 5.10 and Frameworks 5.33.0, so doesn't exist
in 42.2 (or 42.3 for that matter).

If that is your problem, removing the file
/usr/share/dbus-1/services/org.kde.plasma.Notifications.service should "fix"
it (delete it or move it to a different directory, just renaming it won't
help).

Yes - this works.

There are two konsole bug reports that sound similar to your problem, and are
likely have the same cause as the abovementioned bug:
https://bugs.kde.org/show_bug.cgi?id=381115
https://bugs.kde.org/show_bug.cgi?id=380923

I opened an openSUSE bug (1046458) - I'll make a note there of this discussion.

Thanks very much.


--
============================
Roger Whittaker
roger@xxxxxxxxxxxxxxxxx
============================
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >