Mailinglist Archive: opensuse-factory (914 mails)

< Previous Next >
Re: [opensuse-factory] Can't play mp3 files in Amarok


On 28/06/2017 09:53, victorhck wrote:
Hello!

After lastest updates in Tumbleweed I can't play mp3 files with Amarok
or Clementine, but VLC works fine.

If I launch Amarok via CLI I get this:
"Phonon::GStreamer::Backend: Failed to initialize GStreamer
WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no
objectName ) to Phonon::AudioDataOutput ( no objectName ).
WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no
objectName ) to Phonon::AudioOutput ( no objectName ). "

With Clementine I get this:
"GStreamer could not create the element: audioconvert. Please make sure
that you have installed all necessary GStreamer plugins (e.g. OGG and MP3)"

Any clue about this? Thanks in advance.

Greetings.

As Andreas has pointed out, Amarok and Clementine use gstreamer, gstreamer-fluendo-mp3 from the non-free repository in fact.
The last change I made to clementine was three months ago to fix the gcc7 build so this must be something with gstreamer-fluendo-mp3 it wasn't changed since 4 months. The base gstreamer packages were recently updated and it's possible that one of these haven't built or been accepted into Tumbleweed yet. Try refreshing your repositories and checking for new packages. If you still have a problem go to:
https://bugzilla.opensuse.org/enter_bug.cgi?classification=7340&product=openSUSE.org&component=3rd%20party%20software&assigned_to=davejplater@xxxxxxxxx&short_desc=multimedia:apps/clementine:%20Bug
Best regards
Dave Plater
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
References