Mailinglist Archive: opensuse-factory (914 mails)

< Previous Next >
Re: [opensuse-factory] php5 drop
Am 27.06.2017 um 15:37 schrieb Petr Gajdos:
Hey,

I would like to remove php5 from Tumbleweed.

The impulse to consider it is the plan to switch to openssl 1.1 [0].
Support for 5.6 ended on 19 Jan 2017 [1] and upstream will not
backport the changeset related to openssl 1.1 in 5.6 branch [2].

Of course I am planning to create devel:languages:php:php56 and keep
the current version of php 5.6 building there for Tumbleweed as long
as feasible.

I propose to drop php5 from Tumbleweed at the end of August.

Petr

[0] https://bugzilla.suse.com/show_bug.cgi?id=1042629
[1] http://php.net/supported-versions.php
[2] https://bugs.php.net/bug.php?id=73741


Dear Petr,

can't openssl 1.1 and older versions be available in parallel?

Will the next Leap version contain PHP 5.6? If that is the case, for me it
would be ok to remove from factory.

PHP5 Security Support ends at 31 Dec 2018 [1]. It would be great to have PHP in
Leap up to the end. There are still many products around which do not yet work
with PHP7.

--
Johannes Weberhofer
Weberhofer GmbH, Austria, Vienna
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
References