Mailinglist Archive: opensuse-factory (914 mails)

< Previous Next >
Re: [opensuse-factory] Switching default python to Python 3
Hi,

On 27 Jun 11:03, Jiri Slaby wrote:
On 06/26/2017, 03:26 PM, jan matejek wrote:
* note that if a script is using "/usr/bin/python" as shebang (or worse,
"/usr/bin/env python"),
it's already wrong. The shebang must be versioned, unless the script
actually works
with an arbitrary python version

Ugh, this will be tough.

An average system:

# grep '#!.*python$' /usr/bin/*|wc
107 182 4485
# grep '#!.*python[23]' /usr/bin/*|wc
51 52 1936

You can start with fixing llvm which:
* has "#!/usr/bin/env python" and "Requires Python 2.7"
* thus makes the whole Xorg world depend on python 2

python dependencies are only in subpackages which is not a Mesa dependency
(hence Xorg) but I guess I might have missed a file or two, can you tell me
which files you see these dependencies in?

Regards,
ismail

--
SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton,
HRB 21284 (AG Nürnberg)
< Previous Next >
References