Mailinglist Archive: opensuse-factory (914 mails)

< Previous Next >
[opensuse-factory] Re: Acrobat Reader
  • From: Achim Gratz <Stromeko@xxxxxxxx>
  • Date: Mon, 26 Jun 2017 12:53:32 +0200
  • Message-id: <8737an9g0j.fsf@Rainer.invalid>
Achim Gratz writes:
One of the unexpected fallouts of installing that jumbo snapshot was
that the (inofficial) acroread package no longer works (I've removed the
old 32bit version and tried a newer 64bit build with the same result).
Starting the binary seems to hit some SEGV / NULL dereference after
dealing with a lot of font stuff and gtk-im. Does anyone have an idea
how to recover acroread?

So I've tried to replace the exec of the acroread binary with a
catchsegv and get this (three times):

ERROR: ld.so: object
'/usr/lib/Adobe/Reader9/Reader/intellinux/lib/suse-do-not-grab-server.so' from
LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.

The lib in question shows as

/usr/lib/Adobe/Reader9/Reader/intellinux/lib/suse-do-not-grab-server.so: ELF
32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked,
BuildID[sha1]=f77ce5f26f25a200950d34316dce4ae1c3b152da, with debug_info, not
stripped

like others in the same directory. If I suppress the preload, then the
program does in fact grab the X11 server and the program needs to be
killed hard from the console.

I guess the problem here really is that catchsegv also uses an
LD_PRELOAD and 64bit/32bit can't be mixed, but I've no idea how to work
around that. Simply preloading the 32bit libSegFault.so as well doesn't
seem to do anything useful.

I tried to run it in gdb next and that gives this stack trace:

Thread 1 (Thread 0xf4bc7c00 (LWP 6601)):
#0 0xf626b703 in __strpbrk_sse42 () from /lib/libc.so.6
#1 0xf65dac81 in pango_language_matches () from /usr/lib/libpango-1.0.so.0
#2 0xf65dadde in ?? () from /usr/lib/libpango-1.0.so.0
#3 0xf65dae85 in pango_language_get_sample_string () from
/usr/lib/libpango-1.0.so.0
#4 0xf557639f in ?? () from /usr/lib/libpangocairo-1.0.so.0
#5 0xf65dc4f9 in ?? () from /usr/lib/libpango-1.0.so.0
#6 0xf65df32e in pango_layout_line_get_extents () from
/usr/lib/libpango-1.0.so.0
#7 0xf67de673 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#8 0xf67de9db in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#9 0xf65705c8 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#10 0xf65834e1 in ?? () from /usr/lib/libgobject-2.0.so.0
#11 0xf658be69 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#12 0xf658c625 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#13 0xf6972554 in gtk_widget_realize () from /usr/lib/libgtk-x11-2.0.so.0
#14 0xf6973a11 in gtk_widget_set_parent () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x0852690c in _start ()

…which seems to suggest that something in libpango doesn't get checked
thoroughly enough while the initial window gets set up. I'm out of
ideas on what to try next.


Regards,
Achim.
--
+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

SD adaptation for Waldorf microQ V2.22R2:
http://Synth.Stromeko.net/Downloads.html#WaldorfSDada

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups