Mailinglist Archive: opensuse-factory (914 mails)

< Previous Next >
Re: [opensuse-factory] TW Hangs/Crash when rotating Display
Wonko composed on 2017-06-23 11:49 (UTC+0200):
I run a multi screen Setup as such Lenovo X1 Notebook (Displayport) -> Dell
U2715H (DP Chaining) -> Samsung SA850.
The External Screens stand upright so I have to rotate the screens.
This is my xrandr line that worked in the previous months:
xrandr --output eDP1 --primary --mode 2560x1440 --output DP1-8 --mode
2560x1440 --rotate left --right-of eDP1 --output DP1-1 --rotate left --mode
1920x1200 --right-of DP1-8
After Snapshot 2017620 the Names of the DisplayPort outputs changed from
to eDP1 etc) and when I try to run above xrandr setup the system becomes
unresponsive. Sometimes completely crashes. When its only unresponsive it
comes back to life when I unplug the DisplayPort Cable from the Notebook.
Then I see this as a result from the xrandr command:
X Error of failed request:
BadMatch (invalid parameter attributes)
Major opcode of failed request: 140 (RANDR
Minor opcode of failed request: 21 (RRSetCrtcConfig)
Serial number of failed request: 45
Current serial number in output stream: 45
The whole setup behaves very random: Just now when wanted to document the
Error Message it worked and Both external screen came to life.
Any Ideas?.
Check Xorg.0.log to see the connection names found by the driver (and which
driver is being used), then add or remove hyphens from your xrandr script as
required to match. Possibly because of your gfxchip the driver has lately been
changed (e.g. from intel(0) to modeset(0)). Different drivers have traditionally
used different output names, but it seems upstream may have been trying to
consolidate them over recent months.
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata ***
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >