Mailinglist Archive: opensuse-factory (914 mails)

< Previous Next >
Re: [opensuse-factory] snapshot 20170618: libopenmpt wants to install i586 package
On Tue, 2017-06-20 at 12:11 +0100, Peter Suetterlin wrote:
Dominique Leuenberger wrote:

Packages changed:
libopenmpt

From there I get

Problem: libmodplug1-32bit-0.2.8043~beta23-2.1.x86_64 requires
libopenmpt.so.0, but this requirement cannot be provided
uninstallable providers: libopenmpt0-0.2.8043~beta23-
2.1.i586[openSUSE-Tumbleweed]
Solution 1: Following actions will be done:
install libopenmpt0-0.2.8043~beta23-2.1.i586 despite the inferior
architecture
install libphysfs1-2.0.3-182.9.i586 despite the inferior
architecture
install libluajit-5_1-2-2.1.0~beta2-2.1.i586 despite the inferior
architecture
Solution 2: keep obsolete libmodplug1-32bit-0.8.8.5-4.9.x86_64
Solution 3: break libmodplug1-32bit-0.2.8043~beta23-2.1.x86_64 by
ignoring some of its dependencies


Fix for that is underway and should be part of snapshot 0620.

for the time being, I suggest option 2, which will cause the least
problem.

Cheers,
Dominique
< Previous Next >