Mailinglist Archive: opensuse-factory (914 mails)

< Previous Next >
Re: [opensuse-factory] Leap 42.3: Only GTK apps start, all others segfault at startup
Op vrijdag 16 juni 2017 21:35:09 CEST schreef Larx:

Hello,

I have updated my Leap 42.2 to 42.3 (current version as of today).

Not at all 'current' . Leap 42.3 has not been released yet. Where did
you get 
this info?

I know that 42.3 is in beta, and therefore I posted to the factory
mailing list. And therefore what I mean with "current" is the most
recent snapshot of the currently "rolling release" state of 42.3 :-/.


Everything went without a hitch. However, I had to discover that
only GTK
apps still work. I tried that from Gnome and IceWM. The desktop is
there
and GTK apps (maybe other toolkits, too) start. Anything Qt based
crashes
at startup. The same with Firefox. This is on a i915 integrated
graphics
laptop. I also created a blank user account, same situation. I
really don't
know where to find a hint what's going on here. Any ideas?

Larx

Yep, you've upgraded to a not yet finished release.

I know that. However, given the conservative strategy of Leap, in which
42.3 does not really seem so much different than an updated 42.2, I had
the hope not to run into relevant problems.

Having said that, 42.3 runs 
very stable on my test partition, upgrade through 'zypper dup' after
changing 
the repos resulted in a working desktop ( and other things I checked
). The 
phenomena you describe make me think your upgrade strategy was
somehow 
different. 
 

I did two upgrade strategies. One was "zypper dup" from the running
system with the 42.3 repo enabled - only GTK apps start. I went back to
42.2, and tried again by updating with a bootable installation USB
stick. Agsin, only GTK apps start. No Qt, no Firefox, no Chrome...

I fail to see problems with the update strategy.


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups