Mailinglist Archive: opensuse-factory (914 mails)

< Previous Next >
[opensuse-factory] jpackage-utils-java9 & python-javapackages missing?
Hi there- first time sender here and I'm not sure if this is in the
right place. For a couple of weeks now I encounter two problems with
zypper dup --no-allow-vendor-change:

Problem: java-9-openjdk-headless-9.0.0.0~169-1.3.x86_64 requires
jpackage-utils-java9, but this requirement cannot be provided

deleted providers: javapackages-tools-4.6.0-1.3.x86_64
Solution 1: deinstallation of
java-9-openjdk-headless-9.0.0.0~168-1.1.x86_64


Solution 2: keep obsolete
javapackages-tools-4.6.0-1.3.x86_64


Solution 3: break java-9-openjdk-headless-9.0.0.0~169-1.3.x86_64 by
ignoring some of its dependencies


Problem: javapackages-tools-4.6.0-1.3.x86_64 requires
python-javapackages = 4.6.0, but this requirement cannot be provided

deleted providers:
python-javapackages-4.6.0-1.3.x86_64


Solution 1: deinstallation of
java-9-openjdk-9.0.0.0~168-1.1.x86_64


Solution 2: keep obsolete
python-javapackages-4.6.0-1.3.x86_64


Solution 3: break javapackages-tools-4.6.0-1.3.x86_64 by ignoring some
of its dependencies


I can't find these in factory, update, oss, non-oss nor packman repos
and I'm not sure where else to look for official packages. Is this
intentional or can I safely keep these obsolete packages? If I keep
obsoletes, will this maintain only the above two packages at the
obsolete version thereby breaking all other dependent packages, or will
zypper maintain all dependencies at the obsolete level?


Thanks, Jim
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages