Mailinglist Archive: opensuse-factory (914 mails)

< Previous Next >
Re: [opensuse-factory] New rpm macros to test package versions in spec files

Hello,

On May 31 17:01 Antonio Larrosa wrote (excerpt):
Just wondering... let's do a small poll.
How would you call ...
1) The macro that has one argument (package name) and returns its version
number?
a) pkg_version
b) pkg_version_number
c) package_version
d) pkg_ver
other?

c) package_version
because I prefer readability over abbreviations because
in the whole IT we have way too many abbreviations.

2) The macro that has 3 arguments (package_name, operator, version number) and
tests
whether the condition is true or not?
a) pkg_version_test
b) pkg_version_check
c) pkg_version
d) is_pkg_version
e) test_pkg_version
other?

other
because I would like to see a word that is already commonly used
for comparison functionality like "if" or "cmp" i.e. something like
package_version_compare

or for those who think abbreviations are really better:
pkg_version_cmp
pkg_ver_cmp
pkg_vcmp
pvcmp
pvif
pif

nice to see how abbreviations make things more and more incomprehensible
;-)


Kind Regards
Johannes Meixner
--
SUSE LINUX GmbH - GF: Felix Imendoerffer, Jane Smithard,
Graham Norton - HRB 21284 (AG Nuernberg)

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >