Mailinglist Archive: opensuse-factory (520 mails)

< Previous Next >
Re: [opensuse-factory] Tumbleweed snapshot 20170425 broke X in TW Gnome VirtualBox VM
  • From: ianseeks <bingmybong@xxxxxxxxxxxxxx>
  • Date: Mon, 01 May 2017 11:06:29 +0100
  • Message-id: <8635396.uW8a2uScqZ@lianli>
On Sunday, 30 April 2017 22:47:33 BST Robin Klitscher wrote:
On 28/04/17 10:51, Robin Klitscher wrote:
On 28/04/17 07:48, Larry Finger wrote:
When I rebooted after the "sudo zypper update --no-allow-vendorchange",
X failed to start and I get the 1 sec flicker associates with trying to
restart it.

I have not yet figured out which component is broken, nor have I tried
installing that update on my real TW machine. Adding "nomodeset" to the
kernel boot line does not help. Of course, I can boot to mode 3.

I don't know the answer, except to say that you're not alone. I get the
same thing, though it's installed on iron rather than a VM, and in KDE
not Gnome.

After much faffing around I got my desktop back by removing the package
Mesa-dri-nouveau 17.0.4-160.1. The penalty is that I lose my
Plasma5/KDE compositing desktop effects.

This might not help in your case, since mine is a physical installation
with an nVidia video card using the default nouveau drivers, where you
are in a VM and Gnome. But the admonition that comes with the
Mesa-dri-nouveau package that it might not mix well with KDE/Qt seems to
be borne out (though this is the first time I've had trouble with it).

the package Mesa-dri-nouveau 17.0.4-160.1 does seem to prove very meddlesome
at times

--
opensuse:tumbleweed:20170426
Qt: 5.7.1
KDE Frameworks: 5.32.0
KDE Plasma: 5.9.4
kwin 5.9.4
kmail2 5.4.3
akonadiserver 5.4.3
Kernel: 4.10.12-1-default
Nouveau: 1.0.14_2.1

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation