Mailinglist Archive: opensuse-factory (917 mails)

< Previous Next >
Re: [opensuse-factory] rpm Warnings during upgrade: New Tumbleweed snapshot 20170303 released!
dieter <d_werner@xxxxxxx> writes:

On Thu, 16 Mar 2017 22:33:15 +0100
Berthold Höllmann wrote:

( 67/199) Installing:
rpm-4.13.0.1-1.1.x86_64 ..................[done] Additional rpm
output: Updating /etc/sysconfig/services ...


I am getting the same rpm messages. My system is again and again
updated from a SuSE 8 or 9 something. Could it be, that there are
some old left over certificates that lead to this messages?

If so, how can I identify and delete those certificates?

You can search for 'version 3' keys in the output of this command:

for i in `rpm -q gpg-pubkey`; do echo -e "\n\nKey: $i" ;rpm -qi $i |gpg
--list-packets;done

The offending key(s) can be uninstalled just like an rpm package.
In my case it was this key: gpg-pubkey-3d25d3d9-36e12d04
and I removed it with
rpm -e gpg-pubkey-3d25d3d9-36e12d04

Regards,
Dieter

Thank you very much. This (almost) 7 year old key was the culprit on my
system too.

Kind Regards
Berthold
< Previous Next >