Mailinglist Archive: opensuse-factory (930 mails)

< Previous Next >
[opensuse-factory] Tumbleweed - empty screen after restart / no login possible
Hi,

since some days my laptop does not allow to login after reboot.
I always have to open a console (CTRL-ALT-F1) and execute a
"systemctl restart display-manager"
in order to be able to login.

Two different scenarios:

a) after boot I can see the NVIDIA logo for a second and then
(instead of showing the login prompt) I get a blank screen.
"systemctl status display-manager" then shows:

display-manager.service - X Display Manager
Loaded: loaded (/usr/lib/systemd/system/display-manager.service; enabled;
vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2017-03-09 08:00:05 CET; 2min
53s ago
Process: 1900 ExecStop=/usr/lib/X11/display-manager stop (code=exited,
status=0/SUCCESS)
Process: 1519 ExecStart=/usr/lib/X11/display-manager start (code=exited,
status=0/SUCCESS)
Main PID: 1597 (code=exited, status=1/FAILURE)

Mar 09 08:00:00 t510w systemd[1]: Starting X Display Manager...
Mar 09 08:00:01 t510w.privat.loc display-manager[1519]: Starting service
lightdm..done
Mar 09 08:00:01 t510w.privat.loc systemd[1]: Started X Display Manager.
Mar 09 08:00:03 t510w.privat.loc lightdm[1597]: g_object_unref: assertion
'G_IS_OBJECT (object)' failed
Mar 09 08:00:03 t510w.privat.loc lightdm[1873]:
pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
Mar 09 08:00:05 t510w.privat.loc systemd[1]: display-manager.service: Main
process exited, code=exited, status=1/FAILURE
Mar 09 08:00:05 t510w.privat.loc display-manager[1900]: ..done
Mar 09 08:00:05 t510w.privat.loc systemd[1]: display-manager.service: Unit
entered failed state.
Mar 09 08:00:05 t510w.privat.loc systemd[1]: display-manager.service: Failed
with result 'exit-code'.

b) after reboot I see a login screen, can type my name and password,
screen gets blank and then I see the login screen again:

display-manager.service - X Display Manager
Loaded: loaded (/usr/lib/systemd/system/display-manager.service; enabled;
vendor preset: enabled)
Active: active (running) since Thu 2017-03-09 08:08:01 CET; 57s ago
Process: 1516 ExecStart=/usr/lib/X11/display-manager start
(code=exited, status=0/SUCCESS)
Main PID: 1585 (lightdm)
Tasks: 6 (limit: 4915)
CGroup: /system.slice/display-manager.service
├─1585 /usr/sbin/lightdm
├─2716 /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0
-nolisten tcp vt7 -novtswitch
└─2763 lightdm --session-child 13 20

Mar 09 08:08:03 t510w.privat.loc lightdm[1585]: g_object_unref: assertion
'G_IS_OBJECT (object)' failed
Mar 09 08:08:04 t510w.privat.loc lightdm[1867]:
pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
Mar 09 08:08:12 t510w.privat.loc lightdm[1585]: g_object_unref: assertion
'G_IS_OBJECT (object)' failed
Mar 09 08:08:12 t510w.privat.loc lightdm[1912]: pam_unix(lightdm:session):
session opened for user andi by (uid=0)
Mar 09 08:08:16 t510w.privat.loc lightdm[1585]: g_object_unref: assertion
'G_IS_OBJECT (object)' failed
Mar 09 08:08:16 t510w.privat.loc lightdm[2549]:
pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
Mar 09 08:08:22 t510w.privat.loc lightdm[1585]: g_object_unref: assertion
'G_IS_OBJECT (object)' failed


After a restart of displaymanager everything works fine:

"systemctl status display-manager" then says:

display-manager.service - X Display Manager
Loaded: loaded (/usr/lib/systemd/system/display-manager.service; enabled;
vendor preset: enabled)
Active: active (running) since Thu 2017-03-09 08:03:21 CET; 10s ago
Process: 1900 ExecStop=/usr/lib/X11/display-manager stop (code=exited,
status=0/SUCCESS)
Process: 2457 ExecStart=/usr/lib/X11/display-manager start (code=exited,
status=0/SUCCESS)
Main PID: 2502 (lightdm)
Tasks: 7 (limit: 4915)
CGroup: /system.slice/display-manager.service
├─2502 /usr/sbin/lightdm
├─2508 /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0
-nolisten tcp vt7 -novtswitch
└─2556 lightdm --session-child 13 20

Mar 09 08:03:20 t510w.privat.loc systemd[1]: Starting X Display Manager...
Mar 09 08:03:21 t510w.privat.loc display-manager[2457]: Starting service
lightdm..done
Mar 09 08:03:21 t510w.privat.loc systemd[1]: Started X Display Manager.
Mar 09 08:03:22 t510w.privat.loc lightdm[2502]: g_object_unref: assertion
'G_IS_OBJECT (object)' failed
Mar 09 08:03:22 t510w.privat.loc lightdm[2517]:
pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)


Any ideas what goes wrong?

(I'm running the nvidia 340.102 driver with the two patches from nvidia for
kernel_4.9/1
Information is from devtalk.nvidia.com; topic 997549)

Andreas
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages