Mailinglist Archive: opensuse-factory (807 mails)

< Previous Next >
Re: [opensuse-factory] Tumbleweed snapshot question
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On 2017-02-13 10:34, Roger Oberholtzer wrote:
On Mon, Feb 13, 2017 at 10:20 AM, nicholas <> wrote:


If a package has a DRM issue, the openSUSE repos may not contain
the version that accesses the DRM protected content. Packman
libraries, however, will probably allow access. So, it is quite
common that one gets media apps from Packman. If the openSUSE repo
gets a new version before Packman, zypper may want to install that
newer version. If you allow that, you may no longer be able to
access DRM content. So, once you have decided to use the package
from Packman, you probably want to stay with it. Even if the
openSUSE repo may get a new version before Packman. This is true of
many packages for various reasons. The --no-allow-vendor-change
just means that zypper should not update a package from a different
repo without asking if that is what you really want.

No, it will not propose to change to the other repo unless it sees no
other way, and then asking. Otherwise, it will stay at lower release
numbers to keep the vendor, as far as possible.

For instance, another installed package may request a much newer
version...

- --
Cheers / Saludos,

Carlos E. R.

(from 42.2 x86_64 "Malachite" (Minas Tirith))
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iF4EAREIAAYFAlihgjQACgkQja8UbcUWM1z6FQEAnrgQv1kE4XTPyX81cn++44dJ
Z7h/x5UqxAnzCuNpGl4A/0XqvLiX1XLnqvFB1biPxKnYlwzBsR/hwBXpeiIE5u9o
=XFlc
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >